Ir para conteúdo
  • Cadastre-se

Bug crítico no macOS 10.14.4 - E pra Apple, bem... "a culpa é minha!"


Posts Recomendados

Senta que lá vem um pouquinho de história.

 

Desde que atualizei meu MacBook para o macOS 10.14.4 (Build 18E226), notei o seguinte comportamento:

- Você usa o notebook normalmente durante um certo período. Daí vc precisa sair de perto do notebook, fecha a tampa, resolve a vida, abre a tampa, digita a senha e segue o jogo;

- Você repete esse processo umas 2 ou 3x, sempre na normalidade... até que na 4ª vez vc abre a tampa do notebook e a sessão carrega SEM PEDIR TUA SENHA!

E exatamente após isso:

- O processo loginwindow está travado no Monitor de Atividade (e não dá pra matar o processo, nem mesmo forçando);

- As teclas de função (brilho da tela, brilho do teclado, controle de volume, controles multimídia) param de funcionar;

- O app FaceTime não abre (anulando a possibilidade de atender ligações até no próprio iPhone);

- Vc não consegue desligar/reiniciar/fazer logoff no menu da maçã (Pop-up de confirmação não aparece).

Só com "dedoff" (vulgo Desligar no botão, de qualquer jeito) pra restaurar o comportamento correto até que o ciclo se repita.

 

E eis a parte assustadora do negócio:

* FileVault está LIGADO;

* Sistema está configurado p/ pedir minha senha IMEDIATAMENTE após o repouso;

* E tudo isso foi somente após a atualização do macOS para a versão 10.14.4 (18E226).

 

Reportei pra Apple no chat de suporte e tbm. por DM no Twitter @AppleSupport e essa foi a conversa (em resumo):

- "Vocêr já tentou atualizar pra última versão?" -_-'

- "Você já tentou reiniciar a máquina?" -_-' -_-'

- "Você já tentou resetar o SMC?" - Já

- "Você já tentou resetar a NVRAM?" - Já

- "Você já fez o teste com outro usuário logado na máquina?" - Já

- "Então, vou te pedir pra vc agendar um horário numa assistência pois tua máquina tá com defeito!" - Não, Apple... minha máquina não tá com defeito. Hardware dela tá funcionando perfeitamente e tudo isso passou a acotecer somente após essa atualização.

- "Então, não podemos fazer nada se você não agendar um horário em uma assistência para verificar tua máquina! Teu case está cancelado!".

 

E já que a Apple faz de tudo para inibir que o pessoal faça downgrade dos softwares dela (e também porque meu backup do Time Machine já foi atualizado com essa versão), tive q forçosamente baixar o Beta público do 10.14.5 (18F108f) e me livrar dessa brecha - até o momento, tudo normal - mas fica o alerta para quem estiver usando o macOS Mojave e por algum milagre não tiver atualizado pro 10.14.4 (18E226)... evitem!
E pra quem já atualizou, queria saber se já notaram o mesmo ou algo parecido?

É extremamente preocupante saber que o sistema não está protegendo a sessão do usuário devidamente, mesmo com criptografia de disco ativada, mesmo com as configurações forçando para que isso aconteça instantaneamente e a Apple, uma empresa do tamamho que é do valor que adquiriu, se faz de desentendida... bota a culpa no usuário... não admite que o software dela tá bichado... fala que "não tem nada que possa ser feito!", que "você está usando o teu equipamento errado!". E mesmo que haja Radar pra reportar esses bugs, ou eles caem num limbo temporal infinito para alguém dar qualquer resposta daqui uns 10 anos ou simplesmente fecham alegando que o problema já tá sendo tratado (famoso "Duplicate" - o que eu duvido MUITO que realmente esteja).

 

Só porque eu tava contente com o Mojave, até agora... 😕
Saudades, macOS Sierra

Editado por UnderEu
Link para o post
Compartilhar em outros sites
  • Respostas 5
  • Criado
  • Última resposta

Top Postadores Neste Tópico

O meu ainda esta na versão Mojave 10.14.3 mas pede todo dia para atualizar, estou teimando em fazer a atualização justo por medo de algum bug no sistema, como esta rodando liso tudo e tranquilo não vou cair nesta besteira. 

Obrigado pelo aviso UnderEU

Link para o post
Compartilhar em outros sites
  • 2 semanas depois...
  • 3 semanas depois...

Problemas continuam no Developer Beta 5 (18F131a)

Desconfio de q seja algo relacionado esse processo aqui, q por acaso ele apareceu travado na última vez q precisei reiniciar forçadamente a máquina (vulgo há uma hora atrás): https://eclecticlight.co/2019/04/01/back-to-school-studentd-and-classroom-in-mojave-10-14-4


Bom, como é algo que eu nunca vou usar, destruí ele do meu sistema e vamo ver o q acontece.

Editado por UnderEu
Link para o post
Compartilhar em outros sites

Atualização sobre o caso:

 

Depois de 40 e tantos dias passando raiva, testando e retestando tudo quanto é software instalado na minha máquina, reportando tudo quanto é dado de diagnóstico possível para a Apple num radar aberto (e eles não responderam, até agora)... fui investigar a fundo os arquivos de logs na esperança de q eu conseguisse entender alguma coisa em meio às mensagens guardadas.

Problema: o processo loginwindow ia crescendo o número de threads numa taxa de 1 a cada 10s até chegar no limite de 4096; daí o processo travava e iniciava-se os problemas que eu vinha enfrentando - confirmando a média de tempo que ele vinha travando: entre 2 ou 3 dias (que, por coincidência, era a mesma média de vezes que eu abro e fecho a tampa do MacBook). Normalmente, o loginwindow não consome mais que 2 threads.

Daí, lendo o arquivo /var/log/status.log , a seguinte mensagem estava se repetindo exatamente na mesma taxa que o número de threads do loginwindow crescia:

May 12 22:57:27 Unders-Macbook com.apple.xpc.launchd[1] (com.w0lf.dblockinjector): Service only ran for 0 seconds. Pushing respawn out by 10 seconds.

O processo relacionado (com.w0lf.dblockinjector) faz parte de um programa chamado Dark Boot, que troca a cor da tela de boot e personaliza os wallpapers da tela de bloqueio (coisa que o macOS não permite acesso por padrão). Aí, fui pesquisar a Internet afora até chegar nos issues do programa no GitHub e cheguei nesse link, onde a pessoa reportava o exatíssimo mesmo problema q eu tinha mas de uma data bem anterior a atualmente.
Mas aí, comecei a ler e vi que o cidadão reportou que o problema não era o Dark Boot mas sim outro programa chamado gfxCardStatus, cujo objetivo desse é controlar qual GPU está sendo usada nos Macs com opção de GPU dedicada (tipo, a minha máquina) - e eu também uso esse.
Alguma considerações: o gfxCardStatus já não é atualizado há alguns anos mas continuou funcionando pra mim normalmente na sua função principal, inclusive no macOS 10.14.4 e betas da 10.14.5 que usei - daí, me surgiu a pulga atrás da orelha, resolvei fazer o teste desinstalando esse por completo (tirando os arquivos no /Library, /System etc. ) e monitorando o comportamento.

E adivinha... desde esse domingo (12/05/2019), minha máquina tá perfeita; o processo loginwindow tá lá quietinho com seus 2 threads e não tem mais nenhuma ocorrência recorrente nos arquivos de logs. Tudo me leva a crer que, realmente, o problema é o gfxCardStatus - por desencargo, fui conferir as issues dele, não tem nada relacionado nem mesmo sinal de que vai sair alguma atualização e o fork mais atualizado teve o último release no ano passado (pré-Mojave).

 

Bom, se não travar mais até o final dessa semana, vou declarar meu problema como resolvido e já encontrei uma alternativa com suporte atualizado chamada gSwitch. Depois eu volto aqui, pra confirmar se tá resolvido em definitivo.

 


P.S.: E eu realmente achando que foi cagada da Apple, pela infeliz coincidência com a atualização 10.14.4 ... mas ainda mantenho minha crítica, achando q o problema tava no meu hardware e me fazendo marcar horário em assistência pra inventar um problema e me fazer deixar 2 costelas pra arcar com o custo =P

Link para o post
Compartilhar em outros sites

Participe do debate

Você pode postar agora e se registrar depois. Se você tem uma conta, entre agora para postar com ela.

Visitante
Responder este tópico…

×   Você colou conteúdo com formatação.   Remover formatação

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Limpar editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Quem Está Navegando   0 membros estão online

    Nenhum usuário registrado visualizando esta página.




  • Conteúdo Similar

    • Por carlosmsouza
      MacOs: Big Sur 11.2.2
      MacBook Air 2017.

      Boa tarde galera, mais alguém com problemas de travamento e lentidão no app do Excel? 
      Esta horrível de trabalhar.
    • Por vg.br
      Meu SSD orignal da samsung parou de funcionar em 2017, como estava na fora do Brail nao comprei outro ssd por causa do valor, usava ele com hd externo.
      Esse ano achei ssd nvme compatíveis e com um preço razoael, comprei um crucial 500gb. Ele é reconhecido a partir do High Sierra, porém ao realizar a instalação, ele não ccompleta, fica em um loop infitino no Disk Uitility. Na primeira reinicialização. ele volta novamente para o Disk Utility.
      Já  tentei instalar via :
      Sierra ( nem aparece o disk utility, me da um erro do disk utility e vai para instação,  não reconhece o ssd nvme).
      High Sierra(aparece o disk utility, mas fica no loop infinito, tambem tentei alterar a data para 2016 por causa de um update que achei na internet).
      Mojave( aparece o disk utility, mas fica no loop infinito, tambem tentei alterar a data para 2016 por causa de um update que achei na internet).
       
      Gostaria de saber se tem alguma solução para que ele complete a instação.
    • Por tserraia
      Tudo bem pessoal
      Tenho um MacBook Pro (Retina, Mid 2012) com processador 2,3 GHz Intel Core i7 com 8 GB 1600 MHz DDR3  rodando o MOJAVE
      Meu problema é no aplicativo da App Store onde para baixar um novo aplicativo ou fazer uma atualização o ícone de download fica girando por muito tempo e nada acontece.
      Já tentei tudo abaixo e nada resolveu:
      - Fiz um reset no usuário da App Store   “não resolveu”
      - Fiz um reset no aplicativo da App Store  “não resolveu”
      - Formatei a maquina e coloquei o MOJAVE do zero sem nenhum app não nativo  “não resolveu”
      - Instalei o MOJAVE num HD Externo   “não resolveu”
      - Resetei meu roteador da VIVO   “não resolveu”
      - Roteei a internet pelo meu celular   “não resolveu”
      - Baixei uma outra cópia do MOJAVE   “não resolveu”
      - Fiz o PRAM   “não resolveu”
      - Coloquei o Catalina e voltou a funciona mas esta versão do OSX no meu macbook deixa a maquina lenta, quente (que não dá pra ficar no colo) e com as ventoinhas funcionando muito.
      Detalhe que a App Store estava funcionando normalmente no MOJAVE a cerca de 15 dias atrás.
      Um detalhe é que meu MacBook esta sem a bateria (acredito que isto não tenha relação alguma) mas vai saber.
      Será que alguém aqui já passou por isso?
      O problema é que uso apps da App Store e não consigo instala-los
      Obrigado pessoal
       
       

    • Por Raul Duelis
      Fala galera!
      Estou tentando fazer um hackintosh com desktop antiguinho que tenho, com um i3 de 2a geração, placa mãe intel com chipset h61, placa de vídeo AMD Radeon HD 5570 de 1gb e 8gb de RAM ddr3. Já verifiquei que meu hardware é compatível mas estou tendo problemas com o UniBeast. Um processo que era para levar cerca de 20 minutos, no máximo, já dura horas e está aparentemente travado. Inicialmente, apresentava um erro que dizia que o arquivo de Efi (ou algo assim) não podia ser copiado pois estava faltando. Baixei uma nova imagem do High Sierra e o problema persistiu. Baixei uma versão mais recente do UniBeast e agora está assim. Estou criando o pendrive a partir de um MacBook Pro Retina de 2012, com um i5 e 8gb de RAM. Alguém já passou por algo semelhante? Há algum outro programa que eu possa utilizar para criar um pendrive bootavel para criar um hackintosh? 
      Fiz um hackintosh há alguns anos em um notebook HP que tenho com um core 2 duo e tinha conseguido rodar o Yosemite sem maiores problemas...
      Desde já, agradeço! 

    • Por Fernando Braz
      Praticamente nova, configuração de ponta pra rodar tudo, perfeita para edição e criação.
      iMac (Retina 4K, 21.5-inch, 2017)
      Processador: 3 GHz Intel Core i5 Quad-Core
      Memória: 16 GB 2400 MHz DDR4
      SSD 480GB Kingston
      GPU Radeon Pro 555 2 GB
      Não aceito trocas nem propostas absurdas.
      Somente retirada em mãos.
       
       
       
       




    • Por Raul Duelis
      Pessoal, hoje aconteceu uma coisa um pouco estranha... Eu não tenho o costume de desligar meu MacBook todos os dias. Desligo a cada 4 ou 5 dias. Deixei ele carregado ontem e coloquei em repouso. Agora a tarde fui utilizar-lo, desbloqueei e fui encerrar o uTorrent Web. Nesse momento a tela simplesmente desligou. Abaixei a tampa e abri novamente, mas nada. Forcei o desligamento. Ele reiniciou e está normal. Minha bateria está com 2159 ciclos (e apesar de não ser muito considerável, a saúde da bateria está normal). Em uso normal ele dura entre 3 e 4 horas. Em streaming no Spotify, ele já passou de 7h de uso contínuo. Eu tbm não tenho problemas com desligamento súbito. Foi somente este episódio que me chamou a atenção. Alguém já passou por isso? Estou usando o Mac OS Catalina e minha máquina tem um i5 com 8Gb de RAM e 256Gb de SSD
    • Por Jhon B.
      Olá pessoal! 
      Desde as primeiras versões betas do Big Sur logo depois da WWDC até as versões finais e recentemente na versão beta 11.2 venho tendo um comportamento estranho por parte do sistema que insiste em adicionar "oito minutos" em qualquer que seja a tela que precise mostrar as horas, esse problema aparece para mim no calendário, lembretes, protetor de ela e até em aplicativos de terceiros como o Zoom. Já abri vários bug reports por meio do Feedback Assistent nas versões betas do sistemas mas até agora nas betas do 11.2 nada parece ter sido feito pela Apple.
      Abaixo estão alguns prints para vcs verem do que se trata. Alguém mais está tendo esse problema?
       
       


       
    • Por rafael.rosa
      Fala galera, estou com problemas no safari. Normalmente faço muitos uploads pelo Vimeo, então a aba de envio fica aberta por bastante tempo...várias vezes volto para o safari e a aba de envio esta "travada", como se tivesse atualizado e cancelado o envio, aparecendo uma mensagem dizendo que o safari fechou aquela aba pois estava consumindo bastante energia. Alguém sabe como desativar essa opção de fechar abas por energia? Já procurei alguma opção de gerenciamento de energia relacionada ao safari mas não achei nada.
    • Por Dan Bolton
      Olá!
      Não achei um caso parecido com o meu, por isso estou abrindo o tópico.
      Estou com um problema em meu Iphone 6s. O volume de toque dele sempre abaixa após o despertador tocar. Posso colocar o volume no máximo, e quando o alarme toca, ele vibra e aparece o "Toque" na parte superior e a barra de volume no lado esquerdo. Eu até achei que era algum recurso, mas tive a oportunidade de testar um iPhone 8P e um XR e não acontece o mesmo.
      Gravei a tela para mostrar o que acontece: https://drive.google.com/file/d/1TjPGnAUYcpgY91Pa7N2CpOtIHkSzt9W0/view?usp=sharing
      Obrigado!
    • Por Vitor Freire
      Estou com um problema de localização no meu iPhone 7. Achei que fosse um problema do iOS 13.7
      mas vi que persiste no iOS 14
      Todos os apps que utilizam minha localização estão informando a posição errada. Apple Maps,
      Google Maps, Waze, Moovit e até mesmo apps como Uber e 99 estão assim: Estou numa posição X
      na realidade e no sistema informam Y. A diferença são de metros e até quilômetros.
      Possuo automações no app Atalhos que precisam dessa informação. Agora ele não para de enviar notificações.
      Não consigo mais pedir um Uber ou 99 porque eles não sabem onde realmente estou. E também levo cerca de
      30 minutos para usar o Google Maps ou Moovit para procurar por um transporte público porque tenho que achar
      a localização corretas no app.
      No anexo possui 3 exemplos de como está. As screenshots foram tiradas em menos de 10 segundos quando eu
      estava em casa. 
      Mais alguém tem/teve esse problema???



  • Estatísticas do Fórum

    • Total de Tópicos
      51.772
    • Total de Posts
      434.036
×
×
  • Criar Novo...