Ir para conteúdo
  • Cadastre-se

TRIM em SSD de terceiro no High Sierra


AdrianoGH

Posts Recomendados

4 horas atrás, rafarmoreira disse:

MacBook Pro mid 2012

UAI! ?

O meu é Final de 2013 e leva 17s. Quando veio com Mavericks levava 12s. Sabe me dizer como isso é possível pelo seu modelo ser mais antigo? ?

 

Detalhe: bateria, teclado e top case trocados no início do ano

Link para o comentário
Compartilhar em outros sites

11 horas atrás, VICTORHUGOBRAZIL disse:

UAI! ?

O meu é Final de 2013 e leva 17s. Quando veio com Mavericks levava 12s. Sabe me dizer como isso é possível pelo seu modelo ser mais antigo? ?

 

Detalhe: bateria, teclado e top case trocados no início do ano

Depois que instalei o SSD de 500gb da Samsung+ 8gb de ram da Corsair, fiz instalação limpa do High Sierra. Até então dificilmente reinício ou desligo como falei. Quando reinício é mais por conta da atualização do sistema. Última vez de fato que reiniciei sem ser por atualização, gastou uns 10s.

Link para o comentário
Compartilhar em outros sites

Em 23/09/2018 at 13:10, rafarmoreira disse:

Depois que instalei o SSD de 500gb da Samsung+ 8gb de ram da Corsair, fiz instalação limpa do High Sierra. Até então dificilmente reinício ou desligo como falei. Quando reinício é mais por conta da atualização do sistema. Última vez de fato que reiniciei sem ser por atualização, gastou uns 10s.

Seu SSD é o padrão 2,5” de notebooks ou usa aquela plaquinha PCI igual ao meu e os mais recentes?

Link para o comentário
Compartilhar em outros sites

7 minutos atrás, VICTORHUGOBRAZIL disse:

Seu SSD é o padrão 2,5” de notebooks ou usa aquela plaquinha PCI igual ao meu e os mais recentes?

Sim tamanho padrão. Eu usei o adaptador que já veio no HD original de 500gb do Mac. Só tirei o disco mecânico e coloquei o SSD.

Link para o comentário
Compartilhar em outros sites

Em 24/09/2018 at 14:56, rafarmoreira disse:

Sim tamanho padrão. Eu usei o adaptador que já veio no HD original de 500gb do Mac. Só tirei o disco mecânico e coloquei o SSD.

Instalei o Mojave essa semana. Inicialização está bugada, com o logo da maçã desaparecendo e aparecendo de novo. O tempo subiu para 20 segundos

Link para o comentário
Compartilhar em outros sites

  • 7 mês depois...

Bom dia.

Não consigo usar o terminal. Já criei senha de utilizador root, mas quando digito sudo trimforce enable e dou enter, na próxima linha de comando aparece a mensagem para entrar com a senha, ao lado de uma chavinha e não é possível digitar a senha ou qualquer outra coisa. Meu iMac usa o SanDisk SDSSDA240G.

Após a atualização pra o hig sierra 10.13.6 o computador não desliga mais, nem de modo normal e nem usando teclas de atalho; também não reinicia, fica com tela preta e com o cursor livre para se mover sem atuar. No relatório do sistema aparece trim não habilitado, embora eu tenha habilitado o trim quando instalei o sistema no ssd.

Gostaria de receber alguma orientação, para, pelo menos reiniciar e desligar o computador normalmente, sem ter que desligar a fonte de alimentação.

Link para o comentário
Compartilhar em outros sites

Em 23/05/2019 at 09:27, Ademir Moreira disse:

Bom dia.

Não consigo usar o terminal. Já criei senha de utilizador root, mas quando digito sudo trimforce enable e dou enter, na próxima linha de comando aparece a mensagem para entrar com a senha, ao lado de uma chavinha e não é possível digitar a senha ou qualquer outra coisa. Meu iMac usa o SanDisk SDSSDA240G.

Após a atualização pra o hig sierra 10.13.6 o computador não desliga mais, nem de modo normal e nem usando teclas de atalho; também não reinicia, fica com tela preta e com o cursor livre para se mover sem atuar. No relatório do sistema aparece trim não habilitado, embora eu tenha habilitado o trim quando instalei o sistema no ssd.

Gostaria de receber alguma orientação, para, pelo menos reiniciar e desligar o computador normalmente, sem ter que desligar a fonte de alimentação.

Crie um pendrive de boot e reinstale o sistema por cima (não irá perder os arquivos), deve resolver.

Link para o comentário
Compartilhar em outros sites

  • 4 mês depois...
Em 05/02/2018 at 14:33, rafarmoreira disse:

Que eu saiba o TRIM é habilitado automaticamente a parti da versão Sierra. Não precisa usar terminal nem outras ferramentas. 

Fiz upgrade pro mojave e nao ativou automatico! e quando ativo realmente o boot fica bem lento!
Eu estava no EL CAPITAN sem trim e vou manter sem! maior lentidao no boot! :S

Em 16/04/2018 at 07:49, rafarmoreira disse:

@Carlos Alberto de Mendonça eu ativei o trim após instala o SSD Samsung e o macOS High Sierra. Ativei via terminal mesmo. Fiz um teste de leitura e escrita antes e depois de ativar a função, não perde desempenho. Algumas pessoas relataram atraso de boot ao reiniciar ou ligar o Mac quando o trim é habilitado. Mais isso só ocorre com algumas marcas de SSD. Comigo não ocorreu esse problema.

Comigo ocorreu essa lentidao! Uso um SSD Hyperx Fury 240gb! acho que ele nao se da bem com TRIM entao decidi ficar sem!

Link para o comentário
Compartilhar em outros sites

2 horas atrás, Rodolfo.rribeiro disse:

Fiz upgrade pro mojave e nao ativou automatico! e quando ativo realmente o boot fica bem lento!
Eu estava no EL CAPITAN sem trim e vou manter sem! maior lentidao no boot! :S

Comigo ocorreu essa lentidao! Uso um SSD Hyperx Fury 240gb! acho que ele nao se da bem com TRIM entao decidi ficar sem!

Eu uso o Trim habilitado via terminal, o boot apresenta a  mesma rapidez. Meu SSD é Samsung 850 Evo.

Link para o comentário
Compartilhar em outros sites

  • 3 mês depois...

Boa tarde a todos, tenho um Mac mini (Late 2012) e recentemente comprei um Samsung Evo 860 de 500GB, e somente para fixar mais uma informação aqui, no macOS Catalina, com o TRIM ativado via terminal, leva 4 segundos a mais pra iniciar, ou seja com o TRIM desativado ele inicia em 19 segundos, com o TRIM ativado, inicia em 23 segundos. O Catalina foi instalado utilizando APFS, depois de pesquisar muito e não encontrar nada concreto eu resolvi deixar o TRIM desativado kkkk.

Outra coisa que percebi, no meu mac quando inicia, após fazer login e tudo mais, eu tenho alguns scripts de automação que são iniciados utilizando o iTerm2, e com o TRIM ativado, este processo de inicialização do iTerm2 demora 3 segundos a mais.

Como sou desenvolvedor web e apps (android e ios), utilizo máquinas virtualizadas, múltiplos navegadores, etc... Com base nisso entrei em uma paranóia de colocar tudo no HD externo (1TB 7200RPM), cache do Google Chrome, Firefox, Spotify, também instalei todas as minhas VMs no HD externo, além de diversas outras configurações. Minha experiência? Não façam isso kkkk!! No começo estava legal, mas depois o Chrome ficou lento chegando a nem carregar mais vídeos, as minhas máquinas virtuais começaram a dar problemas com lentidão chegando até a travarem e por ai vai.

No fim, deixei somente o cache do Spotify e a pasta Downloads salvas no HD externo, o restante deixei tudo dentro do SSD sem medo de ser feliz e com tudo mais rápido. É aquele negócio, vamos trabalhar pra quando esse SSD acabar, podemos comprar outro, certo? rs!

No Firefox, após entrar nas configurações about:config a única coisa que fiz foi mudar a opção browser.sessionstore.interval para 600000.

No Chrome, limitei o tamanho do cache, mas também não recomendo, mesmo com internet fibra ótica de 300MB, alguns vídeos travam depois de um tempo, exatamente por causa da limitação do Cache.

Bom, agora não sei o quanto isso vai influenciar na vida útil do meu SSD né, mas tudo bem, vamos descobrir! rs

Ta ai o meu depoimento, feliz 2020 a todos.

PS: para quem utiliza o Hombrew e deseja um app de terminal para ver informações do SSD, recomendo o uso do smartmontools:

brew install smartmontools

para ver informações use:

smartctl -a disk0s3

no caso, substitua o "disk0s3" pelo seu disco. Para ver o seu disco no próprio terminal, digite:

diskutil list

\o/

Editado por Gercil Junio
Link para o comentário
Compartilhar em outros sites

O trim é exatamente para não ter que se preocupar com o SSD, visto que com ele ativo, ele não escreve duas vezes no mesmo lugar, já com ela desativado, pode escrever várias e várias vezes no mesmo cluster, e isso é um perigo para SSDs, por essa razão temos SSDs morrendo com poucos anos de vida.

Link para o comentário
Compartilhar em outros sites

Participe do debate

Você pode postar agora e se registrar depois. Se você tem uma conta, entre agora para postar com ela.

Visitante
Responder este tópico…

×   Você colou conteúdo com formatação.   Remover formatação

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Limpar editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Quem Está Navegando   0 membros estão online

    Nenhum usuário registrado visualizando esta página.




  • Conteúdo Similar

    • Por Fernando Braz
      Praticamente nova, configuração de ponta pra rodar tudo, perfeita para edição e criação de conteúdo. Resolução 4k que dispensa comentários.
      NÃO ACOMPANHA TECLADO E MOUSE.
      iMac (Retina 4K, 21.5-inch, 2017)
      Processador: 3 GHz Intel Core i5 Quad-Core
      Memória: 16 GB 2400 MHz DDR4
      SSD 480GB Kingston
      GPU Radeon Pro 555 2 GB
      R$8.900
      Somente retirada em mãos e pagamento via pix.
      Não aceito trocas nem propostas absurdas.

    • Por iDarkness
      Eu amo a Apple em tudo o que ela faz..mas viver em um país onde a moeda e o impostos complicam a vida fica difícil conseguir algum produto Apple
      eu tenho um computador com Windows 7 que segundo minhas pesquisas ele consegue rodar até o Mojave

      mas como alguns posts que eu fiz nesse site eu não consigo  rodar ele direito e já queimei minha placa mãe misteriosamente por isso
      não que seja por ele rodar lento ele roda perfeitamente (testado no High Sierra) mas depois de pelo menos 24h ele não consegue entrar no sistema e depois disso ou eu tenho que desligar e ligar o PC várias vezes para ver se entra no sistema..

      queria muito ter um MacOS no meu PC..mas Hackintosh é algo super complicado pelo menos para min..lembro das horas que passei dor de cabeça pesquisando e pesquisando cada erro minusculo como microfone, auto falante, internet etc.
      infelizmente eu já desistir de tentar fazer Hackintosh mas se você souber me ajudar em alguma informação ou algo que eu não esteja em mente você pode responder
    • Por misael
      Pessoal,

      é possível instalar um SSD M2 (https://www.kabum.com.br/produto/115794/ssd-crucial-p2-500gb-m-2-nvme-leituras-2300mb-s-e-gravacoes-940mb-s-ct500p2ssd8?gclid=CjwKCAjwy42FBhB2EiwAJY0yQvqWRHzDDtNMoR8qi1nkrSZduko9EHL1gyDGO8xKkfQz7rz6IW5T3hoCA3AQAvD_BwE) no Macbook Pro 13' mid 2012? Se possível, o desempenho dele seria melhor do que de um SSD normal?
       
    • Por brunoffc
      Fala, galera 
      Estou necessitado de fazer um upgrade no meu mac pq ele tá extremamente lento e com a bateria já no limite e também pq não tenho 10k pra dar em um novo, mas estou em dúvidas em alguns pontos... 
       
      Qual a melhor marca de bateria disponível para ele? bbbaterias é um bom lugar de se comprar? 
       
      Tem alguma outra memória ram boa para o meu modelo de mac que não seja corsair ou crucial? os preços estão bem salgados... 
       
      SSD eu estou pendendo para o crucial, mas aceito dicas
       
      Deus os abençoe. 
    • Por heberdelia
      Boa noite.
      Tenho um MacBook Air 2017 com o MacOS atualizado e utilizo um HD externo SSD da Samsung para backups de arquivos. Ocorre que estou tendo problemas para copiar arquivos do Mac para essa unidade portátil, sendo que todas as vezes uma tela é apresentada (anexo o print abaixo). Porém, quando transfiro arquivos do pendrive para o disco externo, nada acontece e a transferência ocorre normalmente. O que pode estar ocasionando este problema? Quais os procedimentos devo realizar para sanar esta situação? Desde logo muito obrigado pela atenção.

    • Por Raul Duelis
      Fala galera!
      Estou tentando fazer um hackintosh com desktop antiguinho que tenho, com um i3 de 2a geração, placa mãe intel com chipset h61, placa de vídeo AMD Radeon HD 5570 de 1gb e 8gb de RAM ddr3. Já verifiquei que meu hardware é compatível mas estou tendo problemas com o UniBeast. Um processo que era para levar cerca de 20 minutos, no máximo, já dura horas e está aparentemente travado. Inicialmente, apresentava um erro que dizia que o arquivo de Efi (ou algo assim) não podia ser copiado pois estava faltando. Baixei uma nova imagem do High Sierra e o problema persistiu. Baixei uma versão mais recente do UniBeast e agora está assim. Estou criando o pendrive a partir de um MacBook Pro Retina de 2012, com um i5 e 8gb de RAM. Alguém já passou por algo semelhante? Há algum outro programa que eu possa utilizar para criar um pendrive bootavel para criar um hackintosh? 
      Fiz um hackintosh há alguns anos em um notebook HP que tenho com um core 2 duo e tinha conseguido rodar o Yosemite sem maiores problemas...
      Desde já, agradeço! 

    • Por JoséPauloPedrosa
      Pessoal, acabei de comprar um A1932, com 128 Gb de armazenamento.
      Pretendo dar um upgrade, colocando um SSD de 512 Gb, mas não encontrei nenhuma referência sobre os modelos compatíveis com esse modelo ou ainda se necessita de adaptador.
      Será que alguém sabe informar quais os modelos compatíveis?
    • Por Felipe Feitosa Martins
      Device:
      MacBook Pro 13 Early 2011, quero instalar windows 7 com USB
       
      Estou com o mesmo problema que esse cara
      Quero instalar o win 7 USANDO USB, meu drive optico ferrou!
       
      Quando boota da nisso, solução?
       
    • Por Raul Duelis
      Fala galera!
      Blz?
      Tenho um MacBook Pro 13 Retina, final de 2012, com um core i5, 8Gb de RAM e 256Gb de SSD. Apesar de ter mais da metade de espaço livre, considero um disco pequeno para os padrões de hoje, além do fato de que acho o SSD que nele está, lento (leitura chega a 500Mb reais, enquanto que a leitura fica na casa dos 200Mb). Fui dar uma olhada em SSD da própria Apple mas é uma facada. Estava pensando em aumentar o armazenamento para 512Gb, com um SSD da Kingston, Samsung ou Intel. Alguém sabe me dizer o modelo exato de ssd que preciso? Encontrei nos padrões NVMe M.2 mas tenho dúvida se é isso mesmo. Sei que vou precisar de um adaptador também, pois a conexão dos SSDs Apple é proprietária.
      Ah, se alguém puder indicar um modelo, já ajuda muito!
      Desde já, agradeço, galera!
      Forte abraço!
    • Por Douglas Feltrim
      Pessoal, comprei uma placa lógica para o meu macbook pro e aparentemente tudo certo, ligou certinho. Mas na hora em que fui formatar com o Catalina, ele reinicia.
      Então tentei com o El Capitan e ele instalou, só que depois de um tempo funcionando, ele reinicia.
      Me disseram que pode ser a placa de video dedicada que está com problemas, porém o vendedor da placa disse que testou antes de enviar e estava tudo funcionando corretamente. 
      Alguém teve um problema parecido com esse modelo?
  • Estatísticas do Fórum

    • Total de Tópicos
      52,9k
    • Total de Posts
      441,8k
×
×
  • Criar Novo...