Ir para conteúdo
  • Cadastre-se

Monterey em um iMac 2010 - Deus abençoe o OpenCore Legacy Patcher!


Posts Recomendados

Salve rapaziada!

Eu tenho um iMac 2010 27" véio de guerra, com um SSD no lugar do drive óptico e 12GB de ram. Eu vinha usando o High Sierra, última versão do Mac OS oficialmente suportada, e estava feliz com isso. Me atendia perfeitamente. Até que anteontem eu me deparei com esse vídeo do Ramon Ferreira e resolvi testar.

 

image.png

 

 

Eu já vinha acompanhando o esquema do OpenCore mas sempre fiquei com um pouco de receio porque o processo de instalação era meio complicado, e sempre ficavam alguns bugs, algumas falhas (principalmente relacionadas à GPU nesse meu modelo de iMac). Bom, não mais! Recentemente o pessoal lançou a versão 0.4.5 do opencore e bicho, o negócio é simplesmente espetacular! O processo de instalação é extremamente simples, o Ramon mostra em detalhes nesse vídeo aí de cima. O resultado é sensacional! Tudo funciona com perfeição. Wifi, bluetooth, áudio, transparências nos menus, modo escuro, etc. Não tem mais aqueles problemas gráficos, aquela incompatibilidade com a GPU. Agora tudo funciona bem. E o desempenho é excelente! Eu estou achando o desempenho melhor do que no High Sierra.

Então fica a dica. Se voce tem um Mac mais antiguinho aí, de 2009 pra frente, com um upgrade pra SSD e pelo menos uns 6 ou 8GB de ram, vale a pena testar o open core legacy patcher.

 

Abraço.

Editado por marcosfisica
Link para o comentário
Compartilhar em outros sites

24 minutos atrás, marcosfisica disse:

Salve rapaziada!

Eu tenho um iMac 2010 27" véio de guerra, com um SSD no lugar do drive óptico e 12GB de ram. Eu vinha usando o High Sierra, última versão do Mac OS oficialmente suportada, e estava feliz com isso. Me atendia perfeitamente. Até que anteontem eu me deparei com esse vídeo do Ramon Ferreira e resolvi testar.

 

image.png

 

 

Eu já vinha acompanhando o esquema do OpenCore mas sempre fiquei com um pouco de receio porque o processo de instalação era meio complicado, e sempre ficavam alguns bugs, algumas falhas (principalmente relacionadas à GPU nesse meu modelo de iMac). Bom, não mais! Recentemente o pessoal lançou a versão 0.4.5 do opencore e bicho, o negócio é simplesmente espetacular! O processo de instalação é extremamente simples, o Ramon mostra em detalhes nesse vídeo aí de cima. O resultado é sensacional! Tudo funciona com perfeição. Wifi, bluetooth, áudio, transparências nos menus, modo escuro, etc. Não tem mais aqueles problemas gráficos, aquela incompatibilidade com a GPU. Agora tudo funciona bem. E o desempenho é excelente! Eu estou achando o desempenho melhor do que no High Sierra.

Então fica a dica. Se voce tem um Mac mais antiguinho aí, de 2009 pra frente, com um upgrade pra SSD e pelo menos uns 6 ou 8GB de ram, vale a pena testar o open core legacy patcher.

 

Abraço.

Bicho, eu vi um video no canal do Gabriel Luchina que também me animou a instalar em um MacBook White Unibody Late 2009, vou criar coragem pra fazer a instalação e posto o resultado aqui.

Link para o comentário
Compartilhar em outros sites

Boa, Marcão! O problema mesmo é quando não conseguem fazer funcionar a aceleração gráfica (fácil de constatar se o dock estiver opaco ao invés de transparente), mas que bom que os devs conseguiram fazer um bom trabalho pro teu modelo.

Esse tipo de procedimento não deixa dúvidas de que em alguns casos os devices deixam de receber atualizações não por limitações de hardware mas sim por questões estratégicas/comerciais, ainda que na minha opinião os devices da Apple recebam atualizações oficialmente por um bom tempo.

Penso que o melhor disso tudo é não perder suporte dos softwares por ter uma versão antiga de sistema operacional.

Agora só resta aproveitar! Abrs

Editado por BetoGaleazzo
Link para o comentário
Compartilhar em outros sites

12 horas atrás, joel.cachioli disse:

Eu uso aquele patch do DosDude1 em um Macbook branquinho de 2009. Esse aí é melhor?

os patches do Dosdude vão até o Catalina. O opencore é pro Big Sur e Monterey.

UPDATE - 

Nem tudo são flores. Ontem notei um problema com o Keynote. Consigo abrir e editar arquivos, mas quando mando rodar uma apresentação ele trava. Fica a bolinha colorida da morte no cursor do mouse (mas sem girar, fica estática.). Todo o resto segue funcionando normalmente. O mac continua responsivo, posso ir pra outros programas, tudo norma, só o Keynote travado. É o Keynote 12.

Pode ser algum bug do Keynote, mas acredito que tenha que ver com minha GPU que não teu suporte à api metal. Então to aguardando alguma atualização do opencore.

Link para o comentário
Compartilhar em outros sites

Instalei ontem a noite no MacBook White Unibody Late 2009 e realmente fica quase que impossível utilizar o MacBook, mesmo após a instalação dos patches, Mac com SSD e upgrade máximo de RAM 8GB, como o Marcos mencionou, o que realmente pega nesses Mac antigos é a questão da GPU em relação ao metal.

Link para o comentário
Compartilhar em outros sites

1 hora atrás, marcosfisica disse:

os patches do Dosdude vão até o Catalina. O opencore é pro Big Sur e Monterey

aaaah sim! então é isso hhehe vlw

26 minutos atrás, juliochok disse:

Instalei ontem a noite no MacBook White Unibody Late 2009 e realmente fica quase que impossível utilizar o MacBook, mesmo após a instalação dos patches, Mac com SSD e upgrade máximo de RAM 8GB, como o Marcos mencionou, o que realmente pega nesses Mac antigos é a questão da GPU em relação ao metal.

o meu é igual o seu... acho melhor você continuar no Catalina rs

26 minutos atrás, juliochok disse:

Instalei ontem a noite no MacBook White Unibody Late 2009 e realmente fica quase que impossível utilizar o MacBook, mesmo após a instalação dos patches, Mac com SSD e upgrade máximo de RAM 8GB, como o Marcos mencionou, o que realmente pega nesses Mac antigos é a questão da GPU em relação ao metal.

o meu é igual o seu... acho melhor você continuar no Catalina rs

Link para o comentário
Compartilhar em outros sites

Pessoal só pra informação, se o seu Mac não tiver API metal, para não ter problema com aplicativos, deve utilizar as versões anteriores dos aplicativos a essa API, daí não terá nenhum problema de incompatibilidade dos aplicativos.

 

Ref a quantidade de RAM, eu uso perfeitamente com apenas 4GB, no i5 da assinatura. Como tem API metal os modelos a partir de 2012, fica perfeito!

Editado por webg3brasil
Link para o comentário
Compartilhar em outros sites

50 minutos atrás, webg3brasil disse:

Pessoal só pra informação, se o seu Mac não tiver API metal, para não ter problema com aplicativos, deve utilizar as versões anteriores dos aplicativos a essa API, daí não terá nenhum problema de incompatibilidade dos aplicativos.

 

Ref a quantidade de RAM, eu uso perfeitamente com apenas 4GB, no i5 da assinatura. Como tem API metal os modelos a partir de 2012, fica perfeito!

cara, como faço isso com o Keynote? pra pegar uma versão anterior ao metal, teria que ser o iWork 2013 eu imagino, mas como baixo isso? De onde? Na App Store só baixa a versão mais nova disponível...

Link para o comentário
Compartilhar em outros sites

Atualização sobre o Keynote (e qualquer outro app que estiver bugado):

Procure versões anteriores do app, que não exijam a api metal. No meu caso, o meu problema estava sendo o Keynote, então instalei a versão 9.1 do Keynote, que é de 2019, e tá funcionando perfeitamente.

Link para o comentário
Compartilhar em outros sites

  • 2 semanas depois...

Boa noite!

Já uso a dois anos o OpenCore e não tenho do que reclamar; no meu caso é um iMac de 2013 e um Macbook Pro de 2014, ambos com o Monterey 12.4.

Funciona todo o hardware e o desempenho é excelente, mesmo no Macbook aonde a memória é de 8GB.

Esperando para ver se conseguem fazer funcionar o Ventura.

Tinha um MacBook Pro de 2011 17", até fiz a instalação do Big Sur, mas não ficou legal, porém, li relatos que em outros Mac's do mesmo ano funciona bem.

Link para o comentário
Compartilhar em outros sites

Participe do debate

Você pode postar agora e se registrar depois. Se você tem uma conta, entre agora para postar com ela.

Visitante
Responder este tópico…

×   Você colou conteúdo com formatação.   Remover formatação

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Limpar editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Quem Está Navegando   0 membros estão online

    • Nenhum usuário registrado visualizando esta página.



  • Estatísticas do Fórum

    • Total de Tópicos
      54,2k
    • Total de Posts
      447,2k
×
×
  • Criar Novo...