Ir para conteúdo
  • Cadastre-se

Windows no Parallels não funciona a rede


petterrafael

Posts Recomendados

Pessoal, tenho o seguinte setup:

  • MacOS Big Sur (último Beta disponível
  • Parallels 16 (que a Parallels alega ser totalmente compatível com o Big Sur)

Toda vez que inicializo o Windows recebo a seguinte mensagem: "Falha ao inicializar rede." e o Windows inicia como "Não conecta", mas sem nenhum erro ou conflito nos drivers de rede.

Deixando a configuração padrão dentro da opção Rede do Parallels (configuração Compartilhada), depois de inicializar o Windows e receber o erro essa configuração passa automaticamente para Desconectar.

Alguém já passou por isso ou teria alguma dica? Estou procurando uma referencia para este bug sem sucesso.

Link para o comentário
Compartilhar em outros sites

  • 1 mês depois...
Em 05/10/2020 at 15:58, petterrafael disse:

Pessoal, tenho o seguinte setup:

  • MacOS Big Sur (último Beta disponível
  • Parallels 16 (que a Parallels alega ser totalmente compatível com o Big Sur)

Toda vez que inicializo o Windows recebo a seguinte mensagem: "Falha ao inicializar rede." e o Windows inicia como "Não conecta", mas sem nenhum erro ou conflito nos drivers de rede.

Deixando a configuração padrão dentro da opção Rede do Parallels (configuração Compartilhada), depois de inicializar o Windows e receber o erro essa configuração passa automaticamente para Desconectar.

Alguém já passou por isso ou teria alguma dica? Estou procurando uma referencia para este bug sem sucesso.

Boa noite!

Conseguiu resolver? 

Estou com o mesmo problema

Link para o comentário
Compartilhar em outros sites

  • 2 semanas depois...

Vi uma solução temporária até sair atualização num fórum na gringa.

 

Desliga a virtual machine, fecha tudo do paralela.

abre o terminal no mac

e digita a seguinte linha de comando:

sudo -b /Applications/Parallels\ Desktop.app/Contents/MacOS/prl_client_app
 

digita sua senha, ele aí iniciar uma nova instalação do parallels, vc só autoriza e pode fechar e depois abrir a sua que já está instalada que vai dar certo, porém tem que fazer isso toda vez q iniciar. 
 

uma solução temporária.

Link para o comentário
Compartilhar em outros sites

Em 16/12/2020 at 19:23, Leonardo Costa disse:

Boa noite! alguem ja conseguiu resolver esse problema? estou com a versao 16.1.1, mas nao funciona a rede! a solução temporaria proposta também nao deu certo!

Estou com o mesmo problema... desde o lançamento do Big Sur.

Link para o comentário
Compartilhar em outros sites

Em 16/12/2020 at 19:23, Leonardo Costa disse:

Boa noite! alguem ja conseguiu resolver esse problema? estou com a versao 16.1.1, mas nao funciona a rede! a solução temporaria proposta também nao deu certo!

Finalmente consegui fazer funcionar aqui!
Precisa forçar o Parallels a iniciar sempre com a configuração de rede definida como "Rede compartilhada (Recomendado)". Isto porque sempre que iniciamos o Parallels ele dá erro na rede e coloca essa opção como "Desconectar".

Passo a passo:
1- Desligue a VM e encerre o Parallels Desktop (não precisa fechar o Toobox).
2- Abra o terminal e digite o comando abaixo para editar o arquivo network.desktop.xml

sudo nano /Library/Preferences/Parallels/network.desktop.xml

3- Insira sua senha de administrador
4- Localize o seguinte parâmetro <UseKextless>N</UseKextless>. O valor N provavelmente será "1" ou "-1". Então altere este valor para "0", deixando-o assim: <UseKextless>0</UseKextless>
5- Control + X para sair
6- "Y" para salvar as alterações
7- Enter para finalizar


Pronto, inicia a VM aí e deve funcionar.
Aqui estou com o Big Sur 11.1 e o Parallels Desktop 16.1.1.

Link para o comentário
Compartilhar em outros sites

5 horas atrás, Elton Fabricio disse:

Finalmente consegui fazer funcionar aqui!
Precisa forçar o Parallels a iniciar sempre com a configuração de rede definida como "Rede compartilhada (Recomendado)". Isto porque sempre que iniciamos o Parallels ele dá erro na rede e coloca essa opção como "Desconectar".

Passo a passo:
1- Desligue a VM e encerre o Parallels Desktop (não precisa fechar o Toobox).
2- Abra o terminal e digite o comando abaixo para editar o arquivo network.desktop.xml

sudo nano /Library/Preferences/Parallels/network.desktop.xml

3- Insira sua senha de administrador
4- Localize o seguinte parâmetro <UseKextless>N</UseKextless>. O valor N provavelmente será "1" ou "-1". Então altere este valor para "0", deixando-o assim: <UseKextless>0</UseKextless>
5- Control + X para sair
6- "Y" para salvar as alterações
7- Enter para finalizar


Pronto, inicia a VM aí e deve funcionar.
Aqui estou com o Big Sur 11.1 e o Parallels Desktop 16.1.1.

Cara funcionou aqui!!! Muito obrigado. Forte abraço.

Link para o comentário
Compartilhar em outros sites

Em 18/12/2020 at 15:39, Elton Fabricio disse:

Finalmente consegui fazer funcionar aqui!
Precisa forçar o Parallels a iniciar sempre com a configuração de rede definida como "Rede compartilhada (Recomendado)". Isto porque sempre que iniciamos o Parallels ele dá erro na rede e coloca essa opção como "Desconectar".

Passo a passo:
1- Desligue a VM e encerre o Parallels Desktop (não precisa fechar o Toobox).
2- Abra o terminal e digite o comando abaixo para editar o arquivo network.desktop.xml

sudo nano /Library/Preferences/Parallels/network.desktop.xml

3- Insira sua senha de administrador
4- Localize o seguinte parâmetro <UseKextless>N</UseKextless>. O valor N provavelmente será "1" ou "-1". Então altere este valor para "0", deixando-o assim: <UseKextless>0</UseKextless>
5- Control + X para sair
6- "Y" para salvar as alterações
7- Enter para finalizar


Pronto, inicia a VM aí e deve funcionar.
Aqui estou com o Big Sur 11.1 e o Parallels Desktop 16.1.1.

Criei o cadastro no site somente pra te agradecer!

 

Muito obrigado por compartilhar, funcionou perfeitamente aqui!!

Link para o comentário
Compartilhar em outros sites

13 horas atrás, Dan Furlan disse:

Criei o cadastro no site somente pra te agradecer!

 

Muito obrigado por compartilhar, funcionou perfeitamente aqui!!

Que maravilha! 👊
Aproveite e visite as outras sessões do fórum... tem muito conteúdo bom por aqui! ;)

Link para o comentário
Compartilhar em outros sites

  • 5 semanas depois...

Fiz o procedimento informado, mas percebi queno meu arquivo network.desktop.xml

Não tinha a linha informada, sendo assim adicionei 2 linhas
<UseKextless>0</UseKextless>
<StartNaptd>-1</StartNaptd>

Inseri elas bem no inicio do arquivo abaixo da linha:
<IPv6Enabled>1</IPv6Enabled>

Ai sim funcionou!
Mas obrigado pela dica, foi por ela que eu encontrei essa outra solução, fonte de pesquisa: https://forums.macrumors.com/threads/parallels-16-network-initialization-failed.2268159/page-3

 

Link para o comentário
Compartilhar em outros sites

Em 18/12/2020 at 15:39, Elton Fabricio disse:

Finalmente consegui fazer funcionar aqui!
Precisa forçar o Parallels a iniciar sempre com a configuração de rede definida como "Rede compartilhada (Recomendado)". Isto porque sempre que iniciamos o Parallels ele dá erro na rede e coloca essa opção como "Desconectar".

Passo a passo:
1- Desligue a VM e encerre o Parallels Desktop (não precisa fechar o Toobox).
2- Abra o terminal e digite o comando abaixo para editar o arquivo network.desktop.xml

sudo nano /Library/Preferences/Parallels/network.desktop.xml

3- Insira sua senha de administrador
4- Localize o seguinte parâmetro <UseKextless>N</UseKextless>. O valor N provavelmente será "1" ou "-1". Então altere este valor para "0", deixando-o assim: <UseKextless>0</UseKextless>
5- Control + X para sair
6- "Y" para salvar as alterações
7- Enter para finalizar


Pronto, inicia a VM aí e deve funcionar.
Aqui estou com o Big Sur 11.1 e o Parallels Desktop 16.1.1.

Rapaz... Fui tentar isso, agora o Windows nem abre. 

Aparece a mensagem: 

Captura de Tela 2021-01-22 às 12.19.16.png

 

Desfiz tudo e continua dando erro.... 🤦🏻‍♂️ 

Link para o comentário
Compartilhar em outros sites

  • 2 mês depois...
Em 22/01/2021 at 05:37, ranieriarantes disse:

Fiz o procedimento informado, mas percebi queno meu arquivo network.desktop.xml

Não tinha a linha informada, sendo assim adicionei 2 linhas
<UseKextless>0</UseKextless>
<StartNaptd>-1</StartNaptd>

Inseri elas bem no inicio do arquivo abaixo da linha:
<IPv6Enabled>1</IPv6Enabled>

Ai sim funcionou!
Mas obrigado pela dica, foi por ela que eu encontrei essa outra solução, fonte de pesquisa: https://forums.macrumors.com/threads/parallels-16-network-initialization-failed.2268159/page-3

 

Amigão, valew demais!!!!

Tava com o mesmo problema e com a sua dica funcionou perfeitamente aqui pra mim, finalmente! 

MacOs Big Sur versão 11.2.3

Paralles versão 16.1.2

Link para o comentário
Compartilhar em outros sites

Em 22/01/2021 at 12:20, Del Rei disse:

Rapaz... Fui tentar isso, agora o Windows nem abre. 

Aparece a mensagem: 

Captura de Tela 2021-01-22 às 12.19.16.png

 

Desfiz tudo e continua dando erro.... 🤦🏻‍♂️ 

Caramba, que estranho.
Eu fiz várias edições nesse arquivo e nunca deu problema. É só um arquivo, rs.. tanto que o usuário ranieriarantes chegou até a adicionar as linhas no arquivo dele e funcionou.
Vc fez a edição com a VM desligada? Tentou restaurar aí?

Em 28/03/2021 at 06:00, Hideo disse:

Amigão, valew demais!!!!

Tava com o mesmo problema e com a sua dica funcionou perfeitamente aqui pra mim, finalmente! 

MacOs Big Sur versão 11.2.3

Paralles versão 16.1.2

Showwww!
Feliz em poder ajudar!

Em 21/01/2021 at 17:37, ranieriarantes disse:

Fiz o procedimento informado, mas percebi queno meu arquivo network.desktop.xml

Não tinha a linha informada, sendo assim adicionei 2 linhas
<UseKextless>0</UseKextless>
<StartNaptd>-1</StartNaptd>

Inseri elas bem no inicio do arquivo abaixo da linha:
<IPv6Enabled>1</IPv6Enabled>

Ai sim funcionou!
Mas obrigado pela dica, foi por ela que eu encontrei essa outra solução, fonte de pesquisa: https://forums.macrumors.com/threads/parallels-16-network-initialization-failed.2268159/page-3

 

Mandou bem hein!
Não imaginei que poderia acontecer de não existir essa configuração no arquivo, rs..
Boa dica!

Link para o comentário
Compartilhar em outros sites

Em 29/03/2021 at 10:49, Elton Fabricio disse:

Caramba, que estranho.
Eu fiz várias edições nesse arquivo e nunca deu problema. É só um arquivo, rs.. tanto que o usuário ranieriarantes chegou até a adicionar as linhas no arquivo dele e funcionou.
Vc fez a edição com a VM desligada? Tentou restaurar aí?

Depois de muito tempo consegui reinstalar. 

Mas depois resolvi o problema, mas é meio gambiarra. Abro o Parallels com um comando no Terminal e o wifi vai de boa.

Link para o comentário
Compartilhar em outros sites

5 horas atrás, Del Rei disse:

Depois de muito tempo consegui reinstalar. 

Mas depois resolvi o problema, mas é meio gambiarra. Abro o Parallels com um comando no Terminal e o wifi vai de boa.

Bom, pelo menos está funcionando, né?
O que me deixa puto é o Parallels custar uma fortuna, ter que atualizar todo ano e a gente ainda ter que ficar fazendo gambiarra pra ele funcionar... rs

 

Link para o comentário
Compartilhar em outros sites

  • 2 mês depois...
Em 18/12/2020 at 15:39, Elton Fabricio disse:

Finalmente consegui fazer funcionar aqui!
Precisa forçar o Parallels a iniciar sempre com a configuração de rede definida como "Rede compartilhada (Recomendado)". Isto porque sempre que iniciamos o Parallels ele dá erro na rede e coloca essa opção como "Desconectar".

Passo a passo:
1- Desligue a VM e encerre o Parallels Desktop (não precisa fechar o Toobox).
2- Abra o terminal e digite o comando abaixo para editar o arquivo network.desktop.xml

sudo nano /Library/Preferences/Parallels/network.desktop.xml

3- Insira sua senha de administrador
4- Localize o seguinte parâmetro <UseKextless>N</UseKextless>. O valor N provavelmente será "1" ou "-1". Então altere este valor para "0", deixando-o assim: <UseKextless>0</UseKextless>
5- Control + X para sair
6- "Y" para salvar as alterações
7- Enter para finalizar


Pronto, inicia a VM aí e deve funcionar.
Aqui estou com o Big Sur 11.1 e o Parallels Desktop 16.1.1.

Fiz esse procedimento e não rolou.

BigSur 11.2.3

Parallels 16.5.0

Além do erro "Falha ao inicializar rede" aparecem outras opções no modo brida conforme print. Nenhuma das opções funciona.

Print:https://imgur.com/i5hEiNu

Link para o comentário
Compartilhar em outros sites

  • 4 semanas depois...

Participe do debate

Você pode postar agora e se registrar depois. Se você tem uma conta, entre agora para postar com ela.

Visitante
Responder este tópico…

×   Você colou conteúdo com formatação.   Remover formatação

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Limpar editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Quem Está Navegando   0 membros estão online

    • Nenhum usuário registrado visualizando esta página.
×
×
  • Criar Novo...