Ir para conteúdo
  • Cadastre-se

solução para algumas placas de video no snow leopard e lion.


Posts Recomendados

Comecei com o hackintosh a uns 3 dias e desde então tive que reinstalar o mac mais de 30 vezes por causa da placa de video.

Vo contar como eu consegui instalar o lion 100 por cento nessa configuração e espero que isso ajude as pessoas que estao com dificuldade de terem suas placas reconhecidas pelo os x.

As configurações do meu pc:

Placa mae: Gigabyte GA-945GCM-S2C

Placa de video elitegroup (ecs) 9400gt 512MB

HD: samsung 160Gb

RAM: 2Gb ddr2 667

Processador: Intel dual core e2160 1.8

*detalhe q acho q minha placa mae esta com defeito pq ela ˆqueimaˆ os teclados conectados a ela deichando o F1 ao F2 inutilizaveis, os numeros de cima do teclado nenhum funciona (o 9 e o 0 funcionam so apertando bem forte), o ctrl esquerdo e o delete tmbm nao funciona, ou seja toda vez q tenho q colocar meu email em algum lugar tenho q ir no google e digitar arroba e copiar. alguem ja passo por isso (o botao de interrogação por algum motivo esta abrindo o itunes).

Bom voltando ao assunto principal, comecei com o iatkos s3 v2 (snow leopard 10.6.3) e consegui de primeira, mas sem placa de video, então baixei o iatkos l2 (lion) esse deu trabalho pq sempre q ia dar boot pela primeira vez aparecia uma tela cheia de quadrados brancos q nem uma imagem deformada, ate descobrir q eu devia deselecionar a opção NVenabler e não colocar nada referente a placa de video, blz ai consegui fazer o boot, mas sem internet nem video, a internet eu consegui arrumar instalando um kext da minha placa de rede (RTL8101e), ja a placa de video pesquisei nesse forum e em varios outros italianos e americanos e tentei de tudo, kexts, GraphicsEnabler Y, DLDT, com.apple.boot.plist, osxtools, entre outros, mas a cada tentativa eu tinha que reinstalar do zero o os x por que travava na tela branca (por incrivel q pareça nunca tive um Kernel Panic) até q descobri q no lion o Chameleon nao usa o com.apple.boot.plist da pasta biblioteca/preferences/sistemconfiguration e sim o com.chameleon.boot.plist da pasta raiz /extras ai foi meio caminho andado, ai fui para o snow e impressionantemente no desespero eu selecionei a opção EFI Spring e foi so alegria, estava com o snow com tudo funcionado e decidido a ficar nele, ate que fui sincronizar meu ipad com o itunes e descobri q para sincronizar por wifi eu ia precisar atualizar para o 10.6.8, ai fui eu atras da atualização e vi nesse forum q o iatkos se tiver a kernel vanilla ele atualiza sem problemas mas nao era meu dia de sorte, fui pro tio google e vi sobre usar o multibeast antes de reiniciar o pc e voilá, estava com o 10.6.8, mas pra minha decepção ele tava sem o video, blz, pesquisei varias coisas sobre os EFI String e tentei varias veses mecher no com.apple.boot.plist sem sucesso até que abri o multibeast novamente e selecionei easybeast, aquela q verifica e corrige as permições do disco e o ponto chave é selecionar pci root - 1 fix, ai reiniciei e tava tudo funcionando, mas nao tava feliz :D eu queria o lion por ser mais parecido com o ipad. blz instalei o iatkos l2 tirei a opção NVEnabler, selecionei voodoo 2.7 para o audio e o ps/2 para o teclado e mouse quando deu boot abri o kext helper e coloque o kext da placa de rede e reiniciei depois fui correndo baixar o multibeast e fiz do mesmo modo q tinha feito no snow leopard, não deu outra estou com tudo atualizado rodando 100 por cento, rodando appstore, ps3 media server, itunes, jdownload e tudo funcionando.

aki vo posta como que fico o com.chameleon.boot.plist no lion:


<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE plist PUBLIC "-//Apple//DTD PLIST 1.0//EN" "http://www.apple.com/DTDs/PropertyList-1.0.dtd">
<plist version="1.0">
<dict>
<key>Kernel</key>
<string>mach_kernel</string>
<key>Kernel Flags</key>
<string>npci=0x2000 darkwake=0 PCIRootUID=1</string>
<key>GraphicsEnabler</key>
<string>Yes</string>
<key>Timeout</key>
<string>2</string>
<key>Legacy Logo</key>
<string>Yes</string>
<key>EthernetBuiltIn</key>
<string>Yes</string>
<key>UseKernelCache</key>
<string>Yes</string>
</dict>
</plist>
[/CODE]

Note que o principal foi essa linha:

[u][b]<key>Kernel Flags</key>

<string>npci=0x2000 darkwake=0 PCIRootUID=1</string>[/b][/u]

com isso ele reconheceu a minha placa, não precisei instalar kext nem injetar DLDTs nem nada

Demorei 3 dias achando q era um problemão e no final se resolveu com 3 comandos :S

Aki como fico o com.apple.boot.plist do snow leopard 10.6.8:

[CODE]
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE plist PUBLIC "-//Apple Computer//DTD PLIST 1.0//EN" "http://www.apple.com/DTDs/PropertyList-1.0.dtd">
<plist version="1.0">
<dict>
<key>Kernel</key>
<string>mach_kernel</string>
<key>Kernel Flags</key>
<string></string>
<key>Boot Graphics</key>
<string>Yes</string>
<key>Quiet Boot</key>
<string>No</string>
<key>Timeout</key>
<string>5</string>
<key>device-properties</key>
<string>420200000100000001000000360200000d00000002010c00d041030a010000000101060000010101060000007fff04001e00000072006f006d002d007200650076006900730069006f006e0000000400000022000000400030002c006400650076006900630065005f00740079007000650000000b000000646973706c6179100000004e00560043004100500000001800000004000000000003000c00000000000007000000000e0000006e0061006d00650000000b000000646973706c617914000000400030002c006e0061006d0065000000120000004e5644412c446973706c61792d41100000006d006f00640065006c0000001a0000006e5669646961204765466f72636520393430302047540e0000004e00560050004d000000200000000100000000000000000000000000000000000000000000000000000014000000400031002c006e0061006d0065000000120000004e5644412c446973706c61792d4220000000400031002c0063006f006d00700061007400690062006c00650000000e0000004e5644412c4e564d6163220000005600520041004d002c0074006f00740061006c00730069007a0065000000080000000000002020000000400030002c0063006f006d00700061007400690062006c00650000000e0000004e5644412c4e564d616322000000400031002c006400650076006900630065005f00740079007000650000000b000000646973706c61791c0000006400650076006900630065005f00740079007000650000000f0000004e5644412c506172656e74</string>
</dict>
</plist>
[/CODE]

espero que tenha ajudado alguem, comecei com o mac hoje pq os outros dias foi só reinstalando o mac se isso ajudou alguem comente ai ou tmbm comente se teve alguma dificuldade ou nao intendeu algo que eu escrevi.

ss da mesa (desktop):

10934876.png

Uploaded with ImageShack.us

Link para o post
Compartilhar em outros sites
  • Respostas 0
  • Criado
  • Última resposta

Top Postadores Neste Tópico

Dias Populares

Top Postadores Neste Tópico

Dias Populares

Participe do debate

Você pode postar agora e se registrar depois. Se você tem uma conta, entre agora para postar com ela.

Visitante
Responder este tópico…

×   Você colou conteúdo com formatação.   Remover formatação

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Limpar editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Quem Está Navegando   0 membros estão online

    Nenhum usuário registrado visualizando esta página.




  • Conteúdo Similar

    • Por Bronet
      Olá, estou querendo comprar um MacBook, mas o processador dele é Intel core 2 duo. Compensa comprar e trocar o processador por um melhor (na verdade não sei se tem como fazer isso)? 
      Outra dúvida: placa de vídeo Intel HD graphics 3000 288MB ou 356MB serve para jogar jogos como Alien Isolation e the sims 4?
      Como dá pra ver, não entendo nada do assunto, sejam pacientes ksksks.
    • Por Matheus0498
      Olá
      estou tentando fazer um Hackintosh em um notebook samsung - NP530U3B
      segue configurações base:
      Chipset: Intel 7 Series (Panther Point HM76)
      Processador: Intel Core i5-2537M 
      Codec de Áudio: Realtek ALC269
      GPU Integrada: Intel HD Graphics 3000
      Rede: Realtek RTL8168/8111 
      Wi-Fi: Intel Centrino Advanced-N 6235
      Touchpad: ELAN PS/2 
      Já consegui fazer o Mojave subir segue itens ok:
      Sistema operacional subiu
      Audio com voodoo
      Rede Lan
      USB
       
      mas estou enfrentando um sério problema com a placa de video ela fica somente com 3MB, segui diversos tutoriais nacionais e a grande maioria gringo, mas sem sucesso não sei que caminho percorrer, se alguém tiver alguma ideia oque posso fazer, ficarei grato pela a ajuda.
       
      Segue em anexo a minha config.plist
      EFI 2
       
      config.plist
    • Por Luis Passarella
      Colegas, peço opiniões sobre o que seria melhor: Mac Mini 2012 i7 quadricore 2.6 com placa de vídeo intel graphics 4000 ou Mac Mini 2014 i7 dualcore 3.0 com placa de vídeo intel graphics 5100. Ambos com 16gb. Minha finalidade principal é fotografia em geral com uso de photoshop e similares. Agradeço as sugestões. Ambos estariam com hd fusion drive mas pretendo colocar SSD. Grato. 
    • Por _Eduardo
      Então pessoal, segunda feira de manhã meu iMac 2011 de 21 polegadas simplesmente desligou do nada e quando fui iniciá-lo novamente, a clássica tela de boot cinza com o logo da Apple apareceu com uma série de listras verticais na cor verde. A barra de carregamento chega até a metade e reinicia, e fica nesse loop eterno se eu não desligar. Já tentei entrar no Recovery (não carrega), já tentei também analizar pelo CMD+R mas não dá resultado algum. 
      Fazendo algumas pesquisas, acabei vendo que mais pessoas tiveram o mesmo problema (possivelmente na placa de vídeo), mas 99% dos casos, é na versão de 27 polegadas, e não na de 21.
      Entrei em contato com uma autorizada e falaram que não podem fazer nada por já ser uma máquina defasada. Achei um técnico que "acha que pode arrumar" por R$500, mas estou com medo do cara fazer alguma besteira ainda maior. Ou que a resolução seja temporária.
      Alguma dica de como proceder? Já estou pensando em tentar vender mesmo com esse problema pra tentar montar um PC, mas não tenho ideia de quanto conseguia pegar (muito menos se exite interesse)

    • Por Elissa Barretto
      Boa noite,

      Meu Macbook Pro Retina Mid 2012 parou de funcionar, tela preta mesmo quando ele liga e o teclado também parece não funcionar.
      Levei na assistencia técnica e me deram o laudo de que  o defeito estava na placa de vídeo integrada à Placa Lógica  e estão querendo me cobrar quase 4 mil reais pela substituição de toda a Placa Lógica.

      Vocês podem me indicar alguém que conseguiria resolver o problema de maneira mais justa e barata?
      Em anexo, o laudo e mais detalhes.

      Obrigada
      DAVOS31732.pdf
    • Por Fabiano Henrique De Oliveira Santos
      Pessoal,
      Quero melhorar o desempenho do meu Imac e pra isso quero trocar a placa de vídeo, a minha hoje é de 512 mb.
      Alguem me recomenda alguma?
      Abs
      Fabiano Oliveira
    • Por Erico Tiba
      Amigos, estou com um iMac A1418, ele tem apresentado uma faixa azul na tela preta e não passa disso. A pergunta é, o problema está na tela ou na placa de vídeo? Alguém já viu algo assim?
    • Por Jânio Fábio Queiróz
      Bom dia pessoal
      Tenho um macbook pro i7 15 2011, ele tem 2 chips de video, um da intel e um da nvidia, o chip da nvidia deu problemas, e foi um problema de erro de projeto da apple, teve um recall e durou até o final do anao passado, infelizmente como uso hd ssd a maquina nunca esquentou e o problema apareceu nesse ano, levei na apple e nem vou falar o valor que cobraram.... cambada de sem noçao, dá para comprar um novo.
      Pergunta, tem algum ser que troque este chip ?
      Eu pensei em comprar um placa lógica nova, dá para colocar uma placa mais moderna nesta geração A1286 ano 2011 I7 15 polegadas ?
      Vale a pena vender as peças ?
      Grato
    • Por junkflash
      pessoal, recentemente fiz o processo de Mackintosh em meu PC, porem estou enfrentando alguns problemas no audio no driver da placa de video, minha placa mãe é a ASUS H81M-A ela utiliza o Realtek ALC887, porem quando instalo ele no multbeast apresenta erro, ja tentei instalar também o driver genérico o voodooHDA ele ate instalou mas não aparece nenhuma saída de audio, o outro problema [e com a placa de video, utilizo uma R7 370 e o hack não reconheceu ela, ja instalei o injecta ATI pelo multbeast e mesmo assim continua sem reconhecer.
    • Por MuxAmaral
      Pessoal, Alguem saberia dizer onde posso comprar uma placa de VIDEO Intel iMac 21.5" ATI Radeon HD 5670 512MB . Pode ser no Brasil ou Exterior.
      Obrigado.
  • Estatísticas do Fórum

    • Total de Tópicos
      51.149
    • Total de Posts
      430.141
×
×
  • Criar Novo...