Ir para conteúdo
  • Cadastre-se

Certificado Digital A3 não é exibido no Parallels via Big Sur e Monterey


Poky

Posts Recomendados

Utilizamos o Parallels com Windows 10 para acessar certificados digitais A3. Até o início da semana estava tudo funcionando normalmente, mas de alguns dias para cá, o aplicativo da SafeNet fornecido pela Serasa Experian, apenas exibe o leitor do cartão, mas nada do certificado colocado na leitora.

Tentamos tanto no macOS Big Sur e no Monterey, em máquinas diferentes (iMac Intel e Mac Mini Intel), mas o erro é igual, apenas exibe a leitora, mas nada do certificado. No Windows via Parallels, desinstalamos o aplicativo fornecido pela Serasa Experian e instalamos novamente, e o erro persiste.

Pensamos que podia ser um problema do Windows, criamos novas imagens do Parallels com Windows 10 e Windows 11 e nada, em ambos os macs, mas o erro persiste.

Decidimos instalar o aplicativo diretamente no macOS e funciona tudo normalmente, os certificados são exibidos com sucesso (e-CNPJ e e-CPF), assim como em máquinas com Windows 11 e Windows 10 (não rodando via Parallels), os certificados são exibidos normalmente.

Será que há alguma configuração de segurança do macOS que esteja barrando o compartilhamento do SmartCard para o Parallels?

 

Link para Download: Serasa

Editado por Poky
Link para o comentário
Compartilhar em outros sites

Uma possibilidade também é o aplicativo ter recebido alguma atualização que o fez parar de funcionar em máquinas virtuais, intencionalmente pelo desenvolvedor (como acontece com muitos apps que lidam com dados sensíveis) ou por uma falha na atualização. Você chegou a entrar em contato com o suporte da SafeNet/Serasa pra verificar essa possibilidade?

Se suspeita de configuração do Parallels, já tentou instalar o Parallels e criar uma máquina virtual em outro computador? Digo outra máquina porque as vezes mesmo desinstalando o app (no caso o Parallels) e instalando de novo, pode ser que suas configurações antigas continuem salvas no sistema operacional em algum arquivo de configuração do Parallels que não seja excluído na sua desinstalação.

Link para o comentário
Compartilhar em outros sites

11 horas atrás, Poky disse:

Utilizamos o Parallels com Windows 10 para acessar certificados digitais A3. Até o início da semana estava tudo funcionando normalmente, mas de alguns dias para cá, o aplicativo da SafeNet fornecido pela Serasa Experian, apenas exibe o leitor do cartão, mas nada do certificado colocado na leitora.

Tentamos tanto no macOS Big Sur e no Monterey, em máquinas diferentes (iMac Intel e Mac Mini Intel), mas o erro é igual, apenas exibe a leitora, mas nada do certificado. No Windows via Parallels, desinstalamos o aplicativo fornecido pela Serasa Experian e instalamos novamente, e o erro persiste.

Pensamos que podia ser um problema do Windows, criamos novas imagens do Parallels com Windows 10 e Windows 11 e nada, em ambos os macs, mas o erro persiste.

Decidimos instalar o aplicativo diretamente no macOS e funciona tudo normalmente, os certificados são exibidos com sucesso (e-CNPJ e e-CPF), assim como em máquinas com Windows 11 e Windows 10 (não rodando via Parallels), os certificados são exibidos normalmente.

Será que há alguma configuração de segurança do macOS que esteja barrando o compartilhamento do SmartCard para o Parallels?

 

Link para Download: Serasa

Tenho o mesmo problema aqui.. inclusive testei outras versões anteriores do Safenet e a máquina virtual continua sem reconhecer devidamente o certificado digital.

Link para o comentário
Compartilhar em outros sites

5 horas atrás, BetoGaleazzo disse:

Uma possibilidade também é o aplicativo ter recebido alguma atualização que o fez parar de funcionar em máquinas virtuais, intencionalmente pelo desenvolvedor (como acontece com muitos apps que lidam com dados sensíveis) ou por uma falha na atualização. Você chegou a entrar em contato com o suporte da SafeNet/Serasa pra verificar essa possibilidade?

Se suspeita de configuração do Parallels, já tentou instalar o Parallels e criar uma máquina virtual em outro computador? Digo outra máquina porque as vezes mesmo desinstalando o app (no caso o Parallels) e instalando de novo, pode ser que suas configurações antigas continuem salvas no sistema operacional em algum arquivo de configuração do Parallels que não seja excluído na sua desinstalação.

A versão do SafeNet é a mesma, tanto numa máquina com Windows e com Windows no Paralleles. Realizamos o procedimento de instalação de criar mais uma máquina virtual no macOS que apresentou defeito (iMac), depois fizemos isso em outro macOS (Mac Mini), e nada.

2 horas atrás, autofernando disse:

Tenho o mesmo problema aqui.. inclusive testei outras versões anteriores do Safenet e a máquina virtual continua sem reconhecer devidamente o certificado digital.

Fizemos até o downgrade do Parallels e não resolveu.

Link para o comentário
Compartilhar em outros sites

33 minutos atrás, Poky disse:

Fizemos até o downgrade do Parallels e não resolveu.

Já tentei de tudo também…. Desinstalei e instalei o Windows e o Parallels várias vezes e nada.

E o estranho é que esse problema surgiu de uma hora pra outra, sem eu ter alterado qualquer configuração.

Link para o comentário
Compartilhar em outros sites

1 hora atrás, autofernando disse:

Já tentei de tudo também…. Desinstalei e instalei o Windows e o Parallels várias vezes e nada.

E o estranho é que esse problema surgiu de uma hora pra outra, sem eu ter alterado qualquer configuração.

Exatamente como em nosso caso. A gente está usando certificados fornecidos pela Gemalto e Thales (Serasa Experian), e o problema ocorre apenas no Windows via Parallels.
E no site do Parallels o suporte não atende e não há casos similares na comunidade deles.

Link para o comentário
Compartilhar em outros sites

Eu achava que era algo relacionado ao Windows 11 ARM64 insider preview, que na última build 22483 trouxe vários bugs (no fórum do Parallels há várias pessoas relatando esses erros), mas pelo visto não é decorrente disso, já que você detectou essa mesma inconsistência no certificado digital em Macs Intel e Windows 10.

Eu uso o token pro 72k da Aladdin. 

Enfim, se alguém souber uma solução…

 

Editado por autofernando
Link para o comentário
Compartilhar em outros sites

4 horas atrás, autofernando disse:

Eu achava que era algo relacionado ao Windows 11 ARM64 insider preview, que na última build 22483 trouxe vários bugs (no fórum do Parallels há várias pessoas relatando esses erros), mas pelo visto não é decorrente disso, já que você detectou essa mesma inconsistência no certificado digital em Macs Intel e Windows 10.

Eu uso o token pro 72k da Aladdin. 

Enfim, se alguém souber uma solução…

 

@autofernando Eu estou suspeitando que possa ter relação com a versão do Parallels (Standard). Mas novamente, o suporte do Parallels não serve para nada.

Link para o comentário
Compartilhar em outros sites

3 horas atrás, Poky disse:

@autofernando Eu estou suspeitando que possa ter relação com a versão do Parallels (Standard). Mas novamente, o suporte do Parallels não serve para nada.

@autofernando Parece que apenas a versão Pro permite compartilhar smartcard entre macOS e Windows, mais detalhes: https://kb.parallels.com/123296

O que não faz sentido nenhum, já que usamos por mais de um ano a versão Standard e nunca houve essa limitação.

Editado por Poky
Link para o comentário
Compartilhar em outros sites

@PokySe for isso, realmente é muito estranho, seja porque já utilizávamos a versão standard sem qualquer problema, seja porque é possível selecionar/alternar em qual das máquinas (Windows ou Mac) o certificado digital se conectará. 
 

Vou tentar fazer um trial da versão Pro para verificar.

Editado por autofernando
Link para o comentário
Compartilhar em outros sites

57 minutos atrás, autofernando disse:

@PokySe for isso, realmente é muito estranho, seja porque já utilizávamos a versão standard sem qualquer problema, seja porque é possível selecionar/alternar em qual das máquinas (Windows ou Mac) o certificado digital se conectará. 
 

Vou tentar fazer um trial da versão Pro para verificar.

Eu tentei o trial da Pro em outro mac e não funcionou, ele apenas duplicou o leitor (via Proxy). Agora vou testar é o VMWare Personal.

Editado por Poky
Link para o comentário
Compartilhar em outros sites

28 minutos atrás, Poky disse:

Agora vou testar é o VMWare Personal.

@autofernando No VMWare Fusion Personal ele funcionou, mas não perfeitamente. No início ele apenas mostra novamente o leitor vazio, mas desconectando o leitor via software e depois conectando novamente, o certificado é lido com sucesso.
O que prova que o problema não é o macOS, nem o Windows e nem o SafeNet, e sim o Parallels.

Link para o comentário
Compartilhar em outros sites

7 horas atrás, Poky disse:

@autofernando No VMWare Fusion Personal ele funcionou, mas não perfeitamente. No início ele apenas mostra novamente o leitor vazio, mas desconectando o leitor via software e depois conectando novamente, o certificado é lido com sucesso.
O que prova que o problema não é o macOS, nem o Windows e nem o SafeNet, e sim o Parallels.

Infelizmente vou ter que aguardar alguma solução do Parallels mesmo, porque acho que o VMWare Fusion ainda não roda o Windows ARM no chip M1.
E renovei há pouco tempo minha licença do Parallels…

Link para o comentário
Compartilhar em outros sites

5 horas atrás, autofernando disse:

Infelizmente vou ter que aguardar alguma solução do Parallels mesmo, porque acho que o VMWare Fusion ainda não roda o Windows ARM no chip M1.
E renovei há pouco tempo minha licença do Parallels…

Eu usarei o VMWare como quebra galho, pois ainda temos quase um ano de licença de Parallels, mas não vejo solução a curto prazo. Nosso ticket de suporte aberto com eles na sexta-feira até agora não teve resposta. O suporte deles é péssimo.

Link para o comentário
Compartilhar em outros sites

@Poky ainda não testei, mas achei esse recente artigo de suporte (03/11/2021) no site do Parallels, sobre problemas de conexão USB, recomendando downgrading: 

https://kb.parallels.com/en/128608

No Fórum do Parallels, aliás, tem várias pessoas reclamando sobre a inconsistência de conexão com o USB após a versão 17.1 (lá estão reclamando de controles de Xbox, mas talvez o problema seja semelhante)

https://forum.parallels.com/threads/apple-m1-since-update-of-parallels-desktop-17-1-usb-gamepad-recognized-but-not-working-in-windows-11.355113/

Editado por autofernando
Link para o comentário
Compartilhar em outros sites

3 horas atrás, autofernando disse:

@Poky ainda não testei, mas achei esse recente artigo de suporte (03/11/2021) no site do Parallels, sobre problemas de conexão USB, recomendando downgrading: 

https://kb.parallels.com/en/128608

No Fórum do Parallels, aliás, tem várias pessoas reclamando sobre a inconsistência de conexão com o USB após a versão 17.1 (lá estão reclamando de controles de Xbox, mas talvez o problema seja semelhante)

https://forum.parallels.com/threads/apple-m1-since-update-of-parallels-desktop-17-1-usb-gamepad-recognized-but-not-working-in-windows-11.355113/

@autofernando Obrigado por avisar sobre este artigo. Durante o feriado fizemos o downgrade para a versão 16, mas infelizmente o problema não foi corrigido, tudo continuou da mesma forma.

Editado por Poky
Link para o comentário
Compartilhar em outros sites

11 minutos atrás, Poky disse:

@autofernando Obrigado por avisar sobre este artigo. Durante o feriado fizemos o downgrade para a versão 16, mas infelizmente o problema não foi corrigido, tudo continuou da mesma forma.

@autofernando Lendo o link que você mandou da base de conhecimento deles fez tudo funcionar 😃. Temos que apenas desconectar e conectar novamente o leitor USB e ele é lido com sucesso.

Link para o comentário
Compartilhar em outros sites

  • 2 mês depois...

Participe do debate

Você pode postar agora e se registrar depois. Se você tem uma conta, entre agora para postar com ela.

Visitante
Responder este tópico…

×   Você colou conteúdo com formatação.   Remover formatação

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Limpar editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Quem Está Navegando   0 membros estão online

    • Nenhum usuário registrado visualizando esta página.



  • Estatísticas do Fórum

    • Total de Tópicos
      53,4k
    • Total de Posts
      444,4k
×
×
  • Criar Novo...