Ir para conteúdo
  • Cadastre-se

Instalar macOS 11 Big Sur em Mac’s 2012


Anderson Siqueira

Posts Recomendados

23 horas atrás, Gustavo Pinent disse:

Pois então, primeiro problema. A impressora estava funcionando ok no Big Sur do meu Macbook Pro mid 2012, mas o scanner não. Vi alguns usuários do suporte Apple dizerem que o scanner funcionou após desinstalar, resetar a NVRAM e depois reinstalar. Pois resetei a NVRAM e o macbook não mais aceitou o boot pelo Big Sur! Os outros dois sistemas: Mojave e Windows bootam normal.

Pesquisando, só achei um cara com esse tipo de problema ainda na versão beta, ele corrigiu entrando no shell do Big Sur (eu não consegui) e com os parâmetros:

[code]nvram boot-args=-no_compat_check

reboot[/code]

Faz sentido pois quando tentei definir o volume do Big Sur como disco de boot nas preferências, ele não aceita e diz que falhou a verificação dos arquivos etc.. Depois vou tentar isso aí, agora estou num Linux, mas acho importante essa resposta aparecer aqui - se alguém aí manja de boot, por favor se pronuncie. O reset de NVRAM é um recurso comum, precisamos ter em mente esse workaround para fazê-lo quanto necessário sem perder o boot do Big Sur.

A propósito, o Catalina realmente roda como Big Sur, rodam iguais, e justamente por isso devemos ficar com o Big Sur que é o sistema mais atual. Não sei porque a Apple ainda insiste em manter esses macs no Catalina.

Se usar o OpenCore na EFI interna, poderá executar o reset PRAM (NVRAM) e não perderá o boot, pois o primeiro local que o sistema lê é a EFI, e encontrando o OpenCore, se passará por um Mac compatível. Mas resolve também utilizando o comando acessando o Recovery por um pendrive preparado para o Instalador do Big Sur como o micropatcher.

Link para o comentário
Compartilhar em outros sites

Em 17/04/2021 at 21:12, ricardoviniciusbr disse:

Falae !! Então, esse tutorial está bem facinho e se seguir igual está lá provavelmente não terá problemas, mas sabe como é, se estiver inseguro leia com calma até tomar coragem e claro, veja se sua máquina é um modelo que tem algum detalhe, tem uma lista logo no começo, se der pau vc já vai perceber logo de cara inicializando pelo pen drive, boa sorte aí !

Show. Eu já fiz o procedimento de instalação do Big Sur, só não tinha arriscado ainda com o OpenCore haha. Vou dar uma lida e tentar depois. Valeu.

Link para o comentário
Compartilhar em outros sites

Em 15/04/2021 at 18:41, webg3brasil disse:

vc tem que ir via pendrive, pois como o Mac não é compatível oficialmente, ele ta tentando o Internet Recovery, e não consegue por conta disso, crie um pendrive pelo micropatcher e vc terá acesso ao Instalador e poderá realizar as alterações que deseja, o OpenCore Configurator eu uso apenas para montar a partição EFI interna nem mexo nele. '-)

Poderia dizer quanto de espaço você destinou para a partição EFI?

Link para o comentário
Compartilhar em outros sites

4 horas atrás, pymaciel disse:

Poderia dizer quanto de espaço você destinou para a partição EFI?

acho que ela é de 200MB, como te respondi lá no Telegram, deixa aqui também registrado, é a partição de sistema, a Apple cria essa partição automaticamente, pois utiliza ela para atualizar o firmware, é um setor do sistema sem criptografia, o Windows 10 tem mais ou menos 512MB essa partição, acho que todo o sistema UEFI/EFI cria algo assim. O que fizemos é colocar o bootloader nela, visto que é o primeiro setor lido pelo S.O. antes de iniciar, por causa disso o OpenCore funciona perfeitamente '-)

Link para o comentário
Compartilhar em outros sites

59 minutos atrás, webg3brasil disse:

acho que ela é de 200MB, como te respondi lá no Telegram, deixa aqui também registrado, é a partição de sistema, a Apple cria essa partição automaticamente, pois utiliza ela para atualizar o firmware, é um setor do sistema sem criptografia, o Windows 10 tem mais ou menos 512MB essa partição, acho que todo o sistema UEFI/EFI cria algo assim. O que fizemos é colocar o bootloader nela, visto que é o primeiro setor lido pelo S.O. antes de iniciar, por causa disso o OpenCore funciona perfeitamente '-)

Tranquilo hehe. Eu só não consegui entender ainda como usar o OpenCore configurator pra montar ela e nem se ele já está incluso naquele pacote que você me mandou. 

Link para o comentário
Compartilhar em outros sites

  • 2 semanas depois...

Pessoal que ainda tem esperança do Big Sur em macs antes de 2012, há uma esperança, fizeram alguns patchs no OpenCore Legacy Patcher 1.1.0 que conseguiram trazer de volta o suporte ao OpenGL e algumas GPUs como Nvidia 9400m / 320m e Intel HD Graphics 3000. Dêem uma chance, ainda tem glitches gráficos, mas já é alguma coisa, principalmente para testes e aprendizado.

Link para o comentário
Compartilhar em outros sites

Eu tenho um MacBook Pro 17” 2011 e fiz a instalação do patch nessa versão.

A instalação ocorreu tudo bem e até fiz um rápido uso, mas nesse momento ainda não está “aceitável” o uso.

As ventoinhas acionam demais e ocorre muito travamento, porém, está melhor do que versões anteriores do patch.

Creio que alguns meses consigam deixar excelente igual os 2012 e 2013 (iMac).

Torcendo.

Link para o comentário
Compartilhar em outros sites

Em 01/05/2021 at 22:33, luigustavo disse:

Eu tenho um MacBook Pro 17” 2011 e fiz a instalação do patch nessa versão.

A instalação ocorreu tudo bem e até fiz um rápido uso, mas nesse momento ainda não está “aceitável” o uso.

As ventoinhas acionam demais e ocorre muito travamento, porém, está melhor do que versões anteriores do patch.

Creio que alguns meses consigam deixar excelente igual os 2012 e 2013 (iMac).

Torcendo.

na verdade os macs que não possui api metal só serve mesmo para testes, pois se precisar de usar um Final Cut ou AutoCAD que demanda da GPU, no Big Sur, que depende da api metal, vai acabar crashando esses apps, por isso, só vale como teste mesmo, se quer utilizar algum sistema nesses macs anteriores a 2012, vai de macOS Mojave. Caso tenha algum iMac ou MacPro que é possível trocar a GPU por alguma com suporte à api metal, ai sim vale a troca do sistema e GPU compatível, caso contrário, não vale o esforço. 

Link para o comentário
Compartilhar em outros sites

14 horas atrás, webg3brasil disse:

na verdade os macs que não possui api metal só serve mesmo para testes, pois se precisar de usar um Final Cut ou AutoCAD que demanda da GPU, no Big Sur, que depende da api metal, vai acabar crashando esses apps, por isso, só vale como teste mesmo, se quer utilizar algum sistema nesses macs anteriores a 2012, vai de macOS Mojave. Caso tenha algum iMac ou MacPro que é possível trocar a GPU por alguma com suporte à api metal, ai sim vale a troca do sistema e GPU compatível, caso contrário, não vale o esforço. 

Acho que dessa vez, a Apple conseguiu matar os Mac de 2011 pra baixo, que não suportam metal, como foi feito lá atrás com os Macbooks 4.1 que tem a placa de vídeo GMAx3100.

Pelo jeito eles morreram no Catalina, uma pena pois tem muita máquina boa ficando pra trás ...

Link para o comentário
Compartilhar em outros sites

1 hora atrás, Clodoveu Júnior disse:

Pessoal, socorro!!

Eu ja instalei 784765738 vezes e sempre da o mesmo problema de wifi. 

Eu faço a instalação correta do patch kexts, como da pra ver na imagem, mas quando reinicio a wifi continua desabilitada. 

Alguém poderia me ajudar??

Captura de Tela 2021-05-06 às 12.38.02.png

Que máquina é a sua ? Antes de qq coisa vc tem certeza que o módulo wifi dela não está com problemas ?

Dependendo dá máquina, ja que vc está na tentativa ainda, procura nesse tópico aqui o guia pro Opencore Legacy Patcher e tenta fazer por ele, é mais simples e vc n precisa fazer nada disso depois de instalar, as vezes fica melhor e o sistema roda como nativo.

Link para o comentário
Compartilhar em outros sites

9 horas atrás, ricardoviniciusbr disse:

Que máquina é a sua ? Antes de qq coisa vc tem certeza que o módulo wifi dela não está com problemas ?

Dependendo dá máquina, ja que vc está na tentativa ainda, procura nesse tópico aqui o guia pro Opencore Legacy Patcher e tenta fazer por ele, é mais simples e vc n precisa fazer nada disso depois de instalar, as vezes fica melhor e o sistema roda como nativo.

Conseguii!!

Refiz todos os passos. Desde o downgrade, com a atualização do Catalina, até a reinstalação do Big Sur. 

Da outra vez o Catalina não tava completamente atualizado, o que pode (não sei) ter causado o problema no reconhecimento do Kexts. 

Mas agora ta 100%.

Meu Mac é um MBP 2012 13", 480Gb SSD, 500Gb HD, 16Gb Ram. 

Mto Obrigado pela ajuda!!!

Captura de Tela 2021-05-06 às 23.55.20.png

Link para o comentário
Compartilhar em outros sites

  • 4 semanas depois...

Participe do debate

Você pode postar agora e se registrar depois. Se você tem uma conta, entre agora para postar com ela.

Visitante
Responder este tópico…

×   Você colou conteúdo com formatação.   Remover formatação

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Limpar editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Quem Está Navegando   0 membros estão online

    • Nenhum usuário registrado visualizando esta página.
×
×
  • Criar Novo...