Ir para conteúdo
  • Cadastre-se

Vulnerabilidade envolvendo o APFS expõe a senha do usuário


Matheus Mariano

Posts Recomendados

Fala pessoal do MacMagazine, tudo ok?

Vim aqui discutir sobre o problema de segurança que surgiu com o novo macOS High Sierra e que, muito provavelmente, está relacionado ao novo sistema de arquivos Apple File System (APFS), que está disponível apenas para macs com SSD. Ao criar um novo contêiner criptografado com o APFS, a senha do disco é exposta como dica de senha.

O problema pode ser visto nesse vídeo: 

Alguém mais se deparou com esse problema?

Já reportei à Apple e eles responderam que estão trabalhando nisso.

Achei importante divulgar essa informação, pois muitas pessoas podem ficar vulneráveis a esse problema. Principalmente quem formatar o Mac a partir do High Sierra.

Escrevi um artigo no Medium explicando sobre o ocorrido, que pode ser lido aqui. https://medium.com/@matheusmariano/new-macos-high-sierra-vulnerability-exposes-the-password-of-an-encrypted-apfs-container-b4f2f5326e79

Link para o comentário
Compartilhar em outros sites

  • Respostas 2
  • Criado
  • Última resposta

Top Postadores Neste Tópico

Dias Populares

Top Postadores Neste Tópico

Em 30/09/2017 at 23:38, Matheus Mariano disse:

Fala pessoal do MacMagazine, tudo ok?

Vim aqui discutir sobre o problema de segurança que surgiu com o novo macOS High Sierra e que, muito provavelmente, está relacionado ao novo sistema de arquivos Apple File System (APFS), que está disponível apenas para macs com SSD. Ao criar um novo contêiner criptografado com o APFS, a senha do disco é exposta como dica de senha.

O problema pode ser visto nesse vídeo: 

Alguém mais se deparou com esse problema?

Já reportei à Apple e eles responderam que estão trabalhando nisso.

Achei importante divulgar essa informação, pois muitas pessoas podem ficar vulneráveis a esse problema. Principalmente quem formatar o Mac a partir do High Sierra.

Escrevi um artigo no Medium explicando sobre o ocorrido, que pode ser lido aqui. https://medium.com/@matheusmariano/new-macos-high-sierra-vulnerability-exposes-the-password-of-an-encrypted-apfs-container-b4f2f5326e79

Corrigiram o problema: https://macmagazine.com.br/2017/10/05/apple-disponibiliza-atualizacao-suplementar-10-13-do-macos-high-sierra-com-algumas-correcoes-importantes/

Link para o comentário
Compartilhar em outros sites

Participe do debate

Você pode postar agora e se registrar depois. Se você tem uma conta, entre agora para postar com ela.

Visitante
Responder este tópico…

×   Você colou conteúdo com formatação.   Remover formatação

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Limpar editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Quem Está Navegando   0 membros estão online

    Nenhum usuário registrado visualizando esta página.




  • Conteúdo Similar

    • Por iDarkness
      Eu amo a Apple em tudo o que ela faz..mas viver em um país onde a moeda e o impostos complicam a vida fica difícil conseguir algum produto Apple
      eu tenho um computador com Windows 7 que segundo minhas pesquisas ele consegue rodar até o Mojave

      mas como alguns posts que eu fiz nesse site eu não consigo  rodar ele direito e já queimei minha placa mãe misteriosamente por isso
      não que seja por ele rodar lento ele roda perfeitamente (testado no High Sierra) mas depois de pelo menos 24h ele não consegue entrar no sistema e depois disso ou eu tenho que desligar e ligar o PC várias vezes para ver se entra no sistema..

      queria muito ter um MacOS no meu PC..mas Hackintosh é algo super complicado pelo menos para min..lembro das horas que passei dor de cabeça pesquisando e pesquisando cada erro minusculo como microfone, auto falante, internet etc.
      infelizmente eu já desistir de tentar fazer Hackintosh mas se você souber me ajudar em alguma informação ou algo que eu não esteja em mente você pode responder
    • Por NEOLIGHT
      Pra quem é cliente do Banco do Brasil deve conhecer o app Ourocard. Esse app serve pra gestão das compras, faturas e para geração de cartões virtuais. Eu tinha uns 10 cartões virtuais gerados, nomeados pela empresa ao qual eu usava nos serviços recorrentes (ex:. MercadoPago, Uber, 99, PayPal, minha faculdade, o AliExpress, o Picpay, o RecargaPay), de modo a identificar que empresa daria zebra caso houvesse uma clonagem.
      Ocorreu algo bem esquisito antes de ontem: várias compras foram feitas à minha revelia em um mesmo estabelecimento ("Transvalidadoraps"), com um detalhe muito preocupante: cada compra foi feita usando um cartão virtual DIFERENTE.
      Isso então me seguiu uma grande preocupação, considerando:
      que cada cartão virtual é centralizado no app do BB; que eu usava cada cartão virtual em uma empresa fixa, justamente pra saber que empresa teria problema; que a fraude usou quase toda a lista de números de cartões virtuais, transversalmente; que não fui eu a ceder os números dos cartões a quem quer que seja; que uso um iphone 8 atualizado no último iOS e app BB disponíveis, sem nenhum tipo de jailbreak; COMO o fraudador conseguiu descobrir os números?! Quem vazou os dados? O Banco do Brasil... ou dona Apple tem culpa no cartório? O Banco abriu processo interno pra ressarcir os gastos, mas não sei se ele me dará uma resposta sobre o quê que ocorreu.
      Alguma sugestão, ideia, sinal de fumaça de alguém pra me dar uma luz sobre o caso?
    • Por Raul Duelis
      Fala galera!
      Estou tentando fazer um hackintosh com desktop antiguinho que tenho, com um i3 de 2a geração, placa mãe intel com chipset h61, placa de vídeo AMD Radeon HD 5570 de 1gb e 8gb de RAM ddr3. Já verifiquei que meu hardware é compatível mas estou tendo problemas com o UniBeast. Um processo que era para levar cerca de 20 minutos, no máximo, já dura horas e está aparentemente travado. Inicialmente, apresentava um erro que dizia que o arquivo de Efi (ou algo assim) não podia ser copiado pois estava faltando. Baixei uma nova imagem do High Sierra e o problema persistiu. Baixei uma versão mais recente do UniBeast e agora está assim. Estou criando o pendrive a partir de um MacBook Pro Retina de 2012, com um i5 e 8gb de RAM. Alguém já passou por algo semelhante? Há algum outro programa que eu possa utilizar para criar um pendrive bootavel para criar um hackintosh? 
      Fiz um hackintosh há alguns anos em um notebook HP que tenho com um core 2 duo e tinha conseguido rodar o Yosemite sem maiores problemas...
      Desde já, agradeço! 

    • Por hupert
      Notei algo que me pareceu um possível risco sério de privacidade ao usar o Telegram no IOS 14 (não sei se o mesmo ocorre em outras versões ou no Android). Se um contato da sua agenda troca o número de telefone e um desconhecido adquire o mesmo número, este novo usuário aparecerá na sua lista de contatos do telegram com o nome do contato original, o que em tese, permitiria que a pessoa se passasse pelo seu contato antigo sem que você perceba. Um conhecido tinha dois números de telefones registrados nos contatos do meu telefone. Ele desligou este número e uma outra pessoa adquiriu. Quando esta pessoa entrou no Telegram, apareceu automaticamente na minha lista de contatos com o nome do meu amigo. No entanto, era uma pessoa desconhecida. E isso poderia dar margem à confusão. Eu poderia ter enviado documentos pra ele e um desconhecido receberia! Ao apagar alguns dos meus contatos de pessoas conhecidas cadastradas na agenda do meu telefone, notei que, ao deletar o contato da lista, a página do chat (que precisa ser aberta para poder editar o contato), passa a mostrar o numero ou o nome da pessoa que adquiriu o número. Apareceram, para mim, pessoas que não conheço, que estavam identificadas como contatos meus, pelo fato do número estar ainda cadastrado na minha lista. Em uma outra ocasião, vi o nome de uma amiga e pensei em entrar em contato mas percebi que era outra pessoa na foto, então fiquei na dúvida. Só quando decidi apagar o contato que revelou o nome real da pessoa, que passou a usar o número que era da minha amiga. Na opinião de vocês, isso configuraria um risco de privacidade? Este risco estaria mais relacionado ao IOS ou ao Telegram? O que acham?
    • Por Felipe Feitosa Martins
      Device:
      MacBook Pro 13 Early 2011, quero instalar windows 7 com USB
       
      Estou com o mesmo problema que esse cara
      Quero instalar o win 7 USANDO USB, meu drive optico ferrou!
       
      Quando boota da nisso, solução?
       
    • Por 0xb5q
      Boa tarde pessoal, estou com um baita problemão na hora de formatar um HD "novo" no meu macbook pro, o hd era de um Windows e atualmente ele está completamente vazio, e quando eu uso o utilitário de disco pra tentar formatar ele pra botar o high sierra ele sempre da um erro dizendo "Não foi possível abrir o dispositivo. A operação falhou" e logo depois o HD some da lista de volumes do lado esquerdo do utilitário... aí eu preciso ficar reiniciando ele no modo base (command+r), baixar o OS base e tentar fazer outra formatação em outro formato, Já tentei com  APFS, Mac OS Expandido (Journaling) e o ExFAT, mas sempre dá o mesmo problema, se for de ajuda o HD no qual eu tô tentando formatar é o WDC WD3200BEVT-11CTZ0 Media.
    • Por faustompc
      Pessoal formatei meu macbook Air e instalei o macOS Catalina pela primeira vez. Acontece que o meu hd (Macintosh HD) ficou duplicado e não consigo excluir. Por favor ajudem; se necessário eu posso formatar de novo mas preciso de ajuda pq já tentei e não consegui remover uma das partições. Observem que o Catalina criou uma unidade chamada Macintosh HD e Macintosh HD - Dados 
      Obrigado desde já. 
      Obs.: vejam print em anexo. 

    • Por Murillo Bueno
      Olá, boa tarde, ontem rolou algo no meu Ipad (2018 6th - Atualizado) que eu achei bem estranho!
      Estava no netflix e o seriado q eu estava assistindo não tem completo lá, então quando acabou eu abri pelo safari um site pra assistir online, igual como faço há anos, normal.
      Porém depois de alguns minutos, essa tela de spam simplesmente abriu, spams são bem normais, eu só iria fechar se continuar a assistir, porém a novidade foi que isso travou completamente meu Ipad, nao clicava em nada, e depois de alguns segundos  começou alguma voz, alguém falando algo que não entendi, tinha algumas vozes de fundo, como se fosse alguma sala de comunicação/telemarketing, desliguei o Ipad imediatamente, troquei todas as minhas senhas e o restaurei para as configurações de fábrica.
      Alguém sabe me ajudar? O que foi isso? Desculpa se parecer algo 'bobo', mas eu uso Android e Windows há MUITOS anos e isso nunca aconteceu, não esperava nunca acontecer em um iPad...
       
      Desde já, grato!
       

    • Por tiagofmendes
      E ai, galera. Beleza? Vim compartilhar com vocês o processo de instalação e configuração do meu Hackintosh. 
      Configuração:
      - CPU: Intel i5 3470 LGA 1155
      - Placa mãe: ASUS P8H61-MLX3
      - Memória RAM: 2x 4GB DDR3 1333MZh Kingston
      - GPU: Geforce GT 1030 2GB DDR5 64 bits Nvidia GALAX
      - Armazenamento: SSD 120GB PNY
      - Alimentação: Fonte genérica 200W
      - S.O.: High Sierra 10.13.6
      Pen Drive de Boot: 
      (Pen Drive de no mínimo 8GB)
      Downloads: 
      - UniBeast: 
      https://www.tonymacx86.com/resources/unibeast-8-3-2-high-sierra.383/
      - High Sierra Patcher: 
      http://dosdude1.com/highsierra/
      - MultiBeats:
      https://www.tonymacx86.com/resources/multibeast-10-4-0-high-sierra.401/
      Preparar Pen Drive:
      - Use os downloads recomendados e siga esses passos: 
      https://www.tonymacx86.com/threads/unibeast-install-macos-high-sierra-on-any-supported-intel-based-pc.235474/

      Processo de instalação:
      BIOS
      - Tipo de boot: UEFI
      - Tipo de Sata: AHCI
      - PXE Boot UEFI: Disable
      - Prioridade de boot: USB
      - Vídeo on board: Disable
      - Intel Virtualization Technology: Disable
      BOOT clover
      - Flags: dart=0 nv_disable=1 -v
      - Graphics Injetors: Desmarcar todos
      - Selecionar partição USB (EXTERNAL) para o boot
      Instalção
      - Formate o HD (SSD) pelo Disk Utilite
      - Formato: MacOs expandido (Journaling)
      - Selecione o HD (SSD) para instalão
      Pós Instalção:
      MultBeast
      - UEFI Boot Mode
      - RealtekRTL8111 v2.2.2
      - Clover UEFI Boot Mode
      Driver NVidia
      - Instale o driver da versão do sistema
      https://images.nvidia.com/mac/pkg/387/WebDriver-387.10.10.10.40.105.pkg
      Clover Configurator
      https://www.tonymacx86.com/resources/clover-configurator.429/
      - Mount EFI
      - Open Partition
      - EFI/CLOVER/config.plist
      - Boot: dart=0 nvda_drv=1
      - Graphics: Inject NVidia
      - System Parameters:
      Inject Kexts: Yes
      Inject System ID: Enable
      NVidiaWeb: Enable
      - File Save
      - Reboot
      Driver Audio
      - Instale o driver
      https://sourceforge.net/projects/voodoohda/files/VoodooHDA-2.8.8.pkg.zip/download?use_mirror=ufpr
      Feitos esses passos seu Mac voltará com aceleração gráfica e demais funcionalidades ativas.
      Observação: Nas informações do sistema a placa de vídeo não foi reconhecida, porém está funcionando perfeitamente, fiz testes de stress no hardware e tive um excelente resultado, acredito que uma alteração no FAKE ID possa resolver essa questão de identificação.
      Minha EFI: https://mega.nz/#!AVYEzCjT!JqoKRUtNnH3ylu6mBbzGFV0J2TmRuM71xbsssEHYXdg

      Imagens:
      https://i.ibb.co/cxtyv3H/mac1.jpg
      https://i.ibb.co/1ffg9gT/mac2.jpg
      https://i.ibb.co/hZVC9c1/mac3.jpg
      https://i.ibb.co/JtXGhkR/mac4.jpg
      https://i.ibb.co/Xtj7bh1/mac5.jpg
    • Por esata
      Acabo de instalar o High Sierra 10.13.6  -  Build: 17G65 - Fornecedor: Olarila - Download: Drive
      Ao tentar instalar os drivers com o MultiBeast-High-Sierra-Edition-10.4.0 apareceu uma mensagem informando que a instalação falhou (em anexo).
      obs.: tentei instalar só a placa de som, e deu o mesmo erro.
      Alguma sugestão de como devo proceder?

      Multibeast log:
      05/20/19 08:24:59 - Starting MultiBeast 10.1.1-20171113
      05/20/19 08:44:04 - Installing 'Bootloaders > Clover UEFI Boot Mode'
      05/20/19 08:44:07 - Installing 'BootVolume'
      05/20/19 08:44:07 - Copying 'apfs.efi'
      05/20/19 08:44:07 - Copy of 'apfs.efi' failed.
      'Failed copying apfs.efi'. Exiting.
      05/20/19 08:45:06 - Starting MultiBeast 10.3.0-20180516
      05/20/19 08:47:56 - Installing 'Bootloaders > Clover UEFI Boot Mode'
      05/20/19 08:48:00 - Installing 'BootVolume'
      05/20/19 08:48:01 - Copying 'apfs.efi'
      05/20/19 08:48:01 - Copy of 'apfs.efi' failed.
      'Failed copying apfs.efi'. Exiting.
      05/20/19 22:07:02 - Starting MultiBeast 10.4.0-20180812
      05/20/19 22:09:43 - Failed to find node with path 'Drivers > Audio > Realtek ALCxxx > H310 / B360 / H370 / Q370 Audio Device ID Patch'
      05/20/19 22:09:43 - Failed to find node with path 'Drivers > Audio > Realtek ALCxxx > 200 / Z370 Series / X299 Audio Device ID Patch'
      05/20/19 22:15:06 - Installing 'Bootloaders > Clover UEFI Boot Mode'
      05/20/19 22:15:11 - Installing 'BootVolume'
      05/20/19 22:15:11 - Mounting EFI at destination 'HighSierra'
      05/20/19 22:15:12 - EFI partition for volume does not contain a CLover config.plist. Exiting.
      05/20/19 22:15:59 - Installing 'Bootloaders > Clover UEFI Boot Mode'
      05/20/19 22:16:04 - Installing 'BootVolume'
      05/20/19 22:16:04 - Mounting EFI at destination 'HighSierra'
      05/20/19 22:16:04 - EFI partition for volume does not contain a CLover config.plist. Exiting.
      05/20/19 22:16:56 - Installing 'Bootloaders > Clover UEFI Boot Mode'
      05/20/19 22:17:00 - Installing 'BootVolume'
      05/20/19 22:17:00 - Mounting EFI at destination 'HighSierra'
      05/20/19 22:17:01 - EFI partition for volume does not contain a CLover config.plist. Exiting.
      05/20/19 22:20:23 - Starting MultiBeast 10.4.0-20180812




      DESKTOP:
      ASUS G20CB-B21 Gaming Desktop
      Mobo:  ASUS H170-P/G20CB/DP_MB.
      Processador: Intel Core i7-6700 3.4GHz
      Cooler/WC:  G20AJ CPU FAN ASSY / G20BM THE MOD ASSY
      VGA: NVIDIA GTX 1070 8GB
      WLAN Properties: Realtek 8821AE Wireless LAN 802.11ac PCI-E NIC
      Network Adapter Properties: Network Adapter Realtek 8821AE Wireless LAN 802.11ac PCI-E NIC
      Audio: nVIDIA GP104 HDMI/DP @ nVIDIA GP104 - High Definition Audio Controller PCI - Realtek ALC887 @ Intel Sunrise Point PCH - High Definition Audio Controller [D1] PCI
      Memory: (2x8GB) 16GB DDR4 SDRAM
      SSDs: 120GB Kingston - Hyperx Fury SHFS37A / 120G / 7309541 / 9904447-724.F00G
      HDD: 1TB TOSHIBA DT01ACA100
      Fonte:  ADAPTER 180W 19.5V 3P(5.5PIH) / ADAPTER 230W 19.5V 3P(7.4PHI)


  • Estatísticas do Fórum

    • Total de Tópicos
      52,6k
    • Total de Posts
      439,3k
×
×
  • Criar Novo...