Ir para conteúdo
  • Cadastre-se

Certificado digital


Carlos_Alberto

Posts Recomendados

7 horas atrás, MDetz disse:

Já tentou usar o Firefox ESR?

Muito, muito obrigado! Já guardei o notebook Windows antigo. Tá funcionado agora. Nunca tinha ouvido falar dessa versão ESR.

Compartilhando o que fiz: instalei a versão Firefox ESR e escolhi, das duas que a página do firefox me mostrou, a mais antiga 78 (antes disso testei a outra que é a 91 e não deu certo). Após instalado, fiz o que faria na versão normal v83 do Firefox normal: Firefox > opções (ou preferencias)> privacidade e segurança > dispositivos de segurança > botão “carregar” e digite no campo que será aberto “/Applications/tokenadmin.app/Contents/Frameworks/libaetpkss.dylib” (sem as aspas) e clique OK. Assim voltou a funcionar como era antes.

Link para o comentário
Compartilhar em outros sites

Em 29/10/2021 at 00:03, mktanaka disse:

Muito, muito obrigado! Já guardei o notebook Windows antigo. Tá funcionado agora. Nunca tinha ouvido falar dessa versão ESR.

Compartilhando o que fiz: instalei a versão Firefox ESR e escolhi, das duas que a página do firefox me mostrou, a mais antiga 78 (antes disso testei a outra que é a 91 e não deu certo). Após instalado, fiz o que faria na versão normal v83 do Firefox normal: Firefox > opções (ou preferencias)> privacidade e segurança > dispositivos de segurança > botão “carregar” e digite no campo que será aberto “/Applications/tokenadmin.app/Contents/Frameworks/libaetpkss.dylib” (sem as aspas) e clique OK. Assim voltou a funcionar como era antes.

Fico feliz que tenha dado certo! Aqui no meu Air M1 eu só consigo acessar os sites dos tribunais no Firefox ESR.

Confesso que eu não atualizei pro Monterey ainda pois não sei se o PJE Office, Websigner e Shodo estão funcionando adequadamente. Como diz o ditado, em time que tá ganhando não se mexe. 

Link para o comentário
Compartilhar em outros sites

Utilizamos o Parallels com Windows 10 para acessar certificados digitais A3. Até o início da semana estava tudo funcionando normalmente, mas de alguns dias para cá, o aplicativo da SafeNet fornecido pela Serasa Experian, apenas exibe o leitor do cartão, mas nada do certificado colocado na leitora.

Tentamos tanto no macOS Big Sur e no Monterey, em máquinas diferentes (iMac Intel e Mac Mini Intel), mas o erro é igual, apenas exibe a leitora, mas nada do certificado. No Windows via Parallels, desinstalamos o aplicativo fornecido pela Serasa Experian e instalamos novamente, e o erro persiste.

Pensamos que podia ser um problema do Windows, criamos novas imagens do Parallels com Windows 10 e Windows 11 e nada, em ambos os macs, mas o erro persiste.

Decidimos instalar o aplicativo diretamente no macOS e funciona tudo normalmente, os certificados são exibidos com sucesso (e-CNPJ e e-CPF), assim como em máquinas com Windows 11 e Windows 10 (não rodando via Parallels), os certificados são exibidos normalmente.

Será que há alguma configuração de segurança do macOS que esteja barrando o compartilhamento do SmartCard para o Parallels?

Link para o comentário
Compartilhar em outros sites

Em 18/09/2021 at 12:31, Kobe disse:

Bom dia, Yago! Vi que você citou uma resposta minha do fim de junho, fiquei um tempo fora, acabei não acompanhando o tópico.

Quando peguei o M1, o PJeOffice funcionou no início, depois começou a dar problema do nada. Tentei contato com o TJMG e com o CNJ, não resolveram... Baixei o PJe Office 1.0.20 que um colega disponibilizou aqui no fórum e criei um novo user no Mac. Como meus arquivos ficam na nuvem, a transição foi tranquilo. Por mais absurdo que isso possa parecer, resolveu meu problema do PJeOffice, já que comecei com user "limpo", devia estar dando conflito com alguma coisa instalada. E acabei tendo que comprar um token safenet 5110 (aquele vagalume, antigo, com luzinha na ponta), foi o único que consegui fazer funcionar.

Rapaz, só agora vi sua mensagem e acontece que, desde aquela época, percebi que a criação de um novo usuário funcionava. A solução foi criar um "usuário convidado" e rodar por lá, porque meu Mac tem um outro problema que não consigo resolver: simplesmente não consigo criar um novo usuário "admin" com senha. Quando eu crio e coloco a senha, e tento fazer o login fica dando erro como se a senha estivesse errada, não importa qual eu coloque.

Link para o comentário
Compartilhar em outros sites

  • 2 semanas depois...
Em 14/06/2019 at 19:24, Isaac Batista disse:

Boa noite, algum de vocês recebe mensagem de erro quando inicia o PJEOffice? 

No meu caso, consigo utilizar o firefox com assinatura java (versão 51), mas gostaria de usar a assinatura pelo PJEOffice.

Já instalei o java na versão mais atualizada, tal como o Safenet e o próprio PJEOffice.

A mensagem que recebo é:

Erro ao iniciar o PjeOffice, mensagem interna:null.

No log, consta:

14/06/2019 19:19:20 - Erro na inicialização do assinador, mensagem interna: java.lang.Exception: Erro ao persistir as configurações, mensagem interna: null

Obrigado.

Prezado, tive este mesmo problema e consegui solucionar de duas maneiras.

Só pra ficar claro para os futuros leitores, aqui o problema não está no certificado, mas nas configurações do PJeOffice ou do Java.

Ao iniciar o PJeOffice, ele trava e retorna a seguinte mensagem: "Erro ao iniciar o PjeOffice, mensagem interna:null."

No Log consta: "Erro na inicialização do assinador, mensagem interna: java.lang.Exception: Erro ao persistir as configurações, mensagem interna: null"

 

No meu Mac (Monterey 12.0.1 (21A559) Processador Intel) de duas maneiras diferentes:
* Primeira maneira:
1 - Criei um novo usuário do computador no menu Preferências de Sistema > Usuários e Grupos. Pode ser tanto um novo usuário administrador quanto um usuário comum.
2 - Abri o PJeOffice, que não apresentou nenhum erro.
3 - Cliquei no ícone do PJeOffice, depois na opção Sistema, e cliquei 5 vezes no número da versão para ativar o modo desenvolvedor.
4 - Cliquei no ícone do PJeOffice, depois na opção Configuração de Certificado > PKSC12 > Adicionar e então selecionei meu certificado modelo A1. 
Caso seu certificado seja modelo A3, a opção correta será Configuração de Certificado > PKSC11 > Adicionar e então encontrar a pasta /usr/local/lib e selecionar o driver “libaetpkss.dylib” ou similar
Com isso eu percebi que o problema é algum resquício de registro que ficou gravado nas pastas do usuário, e que não existem no usuário novo.

A partir daí, segui para uma solução em que não seja necessário criar um novo usuário, conforme explico a seguir.

** Segunda maneira: Neste modo não é necessário criar um novo usuário. Fiz tudo utilizando o usuário normal, que no meu caso tem perfil de administrador.
(importante, não esvazie a lixeira nesse processo, pois se não funcionar para você, talvez seja melhor reverter).
1 - Desinstalei Java usando o Terminal com o seguinte comando: 

sudo rm -fr /Library/Internet\ Plug-Ins/JavaAppletPlugin.plugin

sudo rm -fr /Library/PreferencesPanes/JavaControlPanel.prefPane

sudo rm -fr ~/Library/Application\ 

Support/Oracle/Java


2 - Movi o arquivo PJeOffice.app para a lixeira e então excluí o arquivo definitivamente:

3 - Na pasta do usuário atual, usei o atalho SHIFT+COMMAD+. (tecla ponto final) para exibir pastas e arquivos ocultos.

4 - Na pasta oculta ".oracle_jre_usage " movi todos os arquivos para a lixeira.
5 - Na pasta "Biblioteca/Saved Application Sate/net.java.openjdk.cmd.savedState/" , movi todos os arquivos para a lixeira.
6 - Na pasta "Biblioteca/Preferences/" , movi os seguintes arquivos para a lixeira:
   br.jus.cnj.plist
   com.apple.java.util.prefs.plist
7 - Desliguei e liguei o Mac, loguei no meu usuário normal.
8 - Instalei o Java mais atualizado (no momento o Java 8 update 311).
9 - Baixei o arquivo "pje-office_x64.dmg" do site do PJe, abri a imagem e copiei o PJeOffice.app para Aplicativos.
10 - Abri o PJeOffice.app normalmente, que funcionou sem erros. 
11 - Instalei meu certificado modelo A1: Cliquei no ícone do PJeOffice, depois na opção Sistema, e cliquei 5 vezes no número da versão para ativar o modo desenvolvedor. Cliquei no ícone do PJeOffice, depois na opção Configuração de Certificado > PKSC12 > Adicionar e então selecionei meu certificado modelo A1.
Só isso, problema resolvido aqui.
Link para o comentário
Compartilhar em outros sites

  • 2 semanas depois...
Em 19/06/2021 at 20:52, Kobe disse:

Tranquilo, Carlos Alberto! Muito obrigado pela boa vontade, sua dica pode ajudar outros colegas!

Sobre essa perda de microtempo, para quem tem máquina Intel, recomendo o VidaaS, token digital da Valid. Dá para configurar para pedir a senha 1x a cada 7 dias! Para quem tem máquina própria, não compartilha (até por questões de segurança), fica rodando em segundo plano e facilita bastante! Fora que é barato, 49 reais/ano.

Infelizmente, ainda não consegui fazer funcionar no M1...

Carlos, por acaso conseguiu fazer funcionar no M1?

Link para o comentário
Compartilhar em outros sites

  • 4 semanas depois...
  • 3 semanas depois...

Boa tarde!
Estou tentando acessar o e-CAC da Receita Federal pelo Navegador Opera com certificado digital A3, porém toda vez que clico para acessar com o certificado digital o navegador simplesmente pisca a tela e nada acontece.
Alguém sabe como resolver?
Grato.

Monterey v. 12.1

Opera - Versão:82.0.4227.58 (x86_64)

Link para o comentário
Compartilhar em outros sites

Em 19/06/2021 at 20:52, Kobe disse:

Tranquilo, Carlos Alberto! Muito obrigado pela boa vontade, sua dica pode ajudar outros colegas!

Sobre essa perda de microtempo, para quem tem máquina Intel, recomendo o VidaaS, token digital da Valid. Dá para configurar para pedir a senha 1x a cada 7 dias! Para quem tem máquina própria, não compartilha (até por questões de segurança), fica rodando em segundo plano e facilita bastante! Fora que é barato, 49 reais/ano.

Infelizmente, ainda não consegui fazer funcionar no M1...

Tens alguma ideia do que posso fazer para fazer o VidaaS funcionar no M1? Deixo ele aberto já rodando direitinho... Quando abro os documentos no Adobe, não aparece lá :(

Link para o comentário
Compartilhar em outros sites

Em 02/01/2022 at 12:13, Dexterianno disse:

A quem possa interessar, obtive êxito em usar o certificado digital no Mac OS 12 (Monterey) usando um Token Safenet 5110 instalando o driver "SafeNetAuthenticationClient.10.2.111.0" e a extensão "Certisign WebSigner" no Google Chrome.

onde você achou o link para instalar?

Link para o comentário
Compartilhar em outros sites

Bom dia, pessoal 

possuo um token safenet 5110 estou com dificuldade de encontrar um drive que funcione no MacOS Big Sur (11.5.2), processador M1.

Instalei a versão do Safenet Authentication Client 10.2.111.0.

Chega a reconhecer o token, todavia dá erro e fica aparecendo uma exclamação no lugar do token, não podendo acessar qualquer informação do token e sem ser reconhecido.

Alguém sabe como resolver?

segue tela abaixo.

549375989_CapturadeTela2022-01-17as17_21_41.thumb.png.025dcca006d6864f5a74634c196f8ec9.png

Link para o comentário
Compartilhar em outros sites

Participe do debate

Você pode postar agora e se registrar depois. Se você tem uma conta, entre agora para postar com ela.

Visitante
Responder este tópico…

×   Você colou conteúdo com formatação.   Remover formatação

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Limpar editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Quem Está Navegando   0 membros estão online

    • Nenhum usuário registrado visualizando esta página.
×
×
  • Criar Novo...